Find the answer to your Linux question:
Results 1 to 4 of 4
i dual boot - mandrake and winXP. And in my previous 10.0 install I could read/write to the windows vfat partion as a regular user. In the current 10.1 install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5

    How To mount vfat partition


    i dual boot - mandrake and winXP. And in my previous 10.0 install I could read/write to the windows vfat partion as a regular user. In the current 10.1 install (t'was not an upgrade) i cannot access the same partition as a regular user, but i can access it as su.

    in a terminal as su i've tried chmod and chown and the system tells me i don't have sufficient privileges. I've even logged out as reg user and logged back in as root... no luck there either.

    here's the pertinent entry from fstab: /dev/hdb5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850 0 0

    any suggestions about how i can access the vfat as a regular user?

    frank

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    does your reading on ls -l shows that you do not have rw capability?
    add ,users to your fstab entry in the 4th option
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    yep.. ls -l tells me only root can rwx. Everyone else is r. And as i mentioned, chmod or chown doesn't change this.

    would the addition of users to fstab look something like this:
    /dev/hdb5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850, users 0 0

    frank

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    5
    got it to work..


    here's the fstab entry:
    /dev/hdb5 /mnt/win_d vfat umask=0,iocharset=iso8859-1,codepage=850,users 0 0

    pretty sure it's the umask=0 that did it, as that essentially mounts the partition with file permissions of 777. The ,users entry is probably unecessary, but i'll leave it for the time being.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •