Find the answer to your Linux question:
Results 1 to 7 of 7
Ok, I have a hard drive in the ext3 format. It was connected to a Linksys NSLU2 network storage link. The link went bad and I need to get the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26

    Totally new to linux!


    Ok, I have a hard drive in the ext3 format. It was connected to a Linksys NSLU2 network storage link. The link went bad and I need to get the data off the hdd. I have Mandrake 10 and installed it on a pc. I try to access the hdd and it is always locked. It says I dont have enough permissions to access it. What do I do to access it?
    thanks.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Have you tryed as root.
    Please post the way you've tryed to get the actual data

    Thanks

    EDIT : What do you mean by the link went bad?
    whats this device? usb, ethernet HD, ...
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    How do I try as root?

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Login with root as the username and use the root pass for the password
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    Ok, but how??
    when I go to login , it brings up a box with the "available" usernames in there. I only have one username, so I click it and it will only allow me to type the password???

  6. #6
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    If you log in from the console, just type "root", hit enter, and enter the root password. Depending on your GUI, you may be able to type in a user name here as well. If you can't, log in under your normal name, go to a command prompt, type "su" (switch user command), and then the root password. You now have root capabilities and privileges for any commands run within the console. As for making sure the harddrive is properly mounted, I can't help you too much there.
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    OK, again, I cant type anything when I log in...it gives me the available usernames, I can only select one, then I can type a password for it. I cannot change to a different username.
    As far as the su, I tried that and now the dev folder comes up as locked and I can access that.
    I think I'm gonna try a new install of mandrake and see what that does.

    Does anyone know of a program that will read ( and allow me to copy ) ext3 files in windows???
    I tried explore2fs but its not working, anything else?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •