Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 37
ok, I'm trying to share a disc to a windows network. I add the shares in the samba.conf, then go to save it and I dont have permission...( seems I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26

    cant save anything??


    ok, I'm trying to share a disc to a windows network.
    I add the shares in the samba.conf, then go to save it and I dont have permission...( seems I dont have permission to do anything in linux!!! getting annoying!) So how do I give myself permission to do things without having to be logged in as root??

    Another thing...I have a second hd installed that shows up in harddrake but it doesnt show up in mounts...is it supposed to?

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157

    Re: cant save anything??

    Quote Originally Posted by Frunple
    Another thing...I have a second hd installed that shows up in harddrake but it doesnt show up in mounts...is it supposed to?
    You will have to mount the drive I think with
    Code:
    mount /dev/hdb /mnt/disk2
    replace hdb with the disk name and /mnt/disk2 with were you want tomount your drive.

    p.s. you might have to use su;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    ok, in harddrake the name is hdb so I used that :

    mount /dev/hdb /mnt/disk2

    exactly what I typed.

    I got back:
    mount: mount point /mnt/disk2 does not exist

    ????

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    The mount point you specified didn't exist so you have to create it with :
    Code:
    mkdir /mnt/disk2
    now try and mount the drive

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    now I have to specify fs type.
    So I did:
    mount [-t ext3] /dev/hdb /mnt/disk2

    didnt work.

  6. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    I think itshould be :
    Code:
    mount -t ext3 /dev/hdb /mnt/disk2
    and I take it that the drive is ext3 and not another kind.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    26
    yes it is ext3.
    I tried that as well and get:

    mount: wrong fs type, bad option, bad superblock on /dev/hdb,
    or too many mounted file systems

    anymore ideas?
    sorry to keep going here but I have some stuff on that drive that I need to get.
    Thanks for all your help.

  8. #8
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    are you sure that /dev/hdb is the drive you want? hdb was only an example

  9. #9
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    do you have any other drives/partitions you can unmount and then try and mount hdb?

    grasping at straws: try another file system type maybe? like ext2?

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  10. #10
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Quote Originally Posted by lakerdonald
    are you sure that /dev/hdb is the drive you want? hdb was only an example
    ok, in harddrake the name is hdb so I used that :

    mount /dev/hdb /mnt/disk2
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •