Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Any ideas on how to get this mouse's scroll button to work? The other buttons work o.k. but i haven't been able to get the scroll button to function. We're ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67

    Logitech First Wheel Mouse - Scroll Not Working


    Any ideas on how to get this mouse's scroll button to work? The other buttons work o.k. but i haven't been able to get the scroll button to function. We're using Mandrake 10.1. We went to the Logitech website, but there are no downloads for Linux... If we have to edit some conf file, i think we have tried that, but are denied write access in gedit. We can see the file contents, but are unable to edit it.
    Have a nice evening!

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You have to edit the file as root/superuser. You can do this in KDE by running your editor from ALT+F2 and selecting "Run as a Different User" (something like that ). Type in root here and put in your root password. Now you can edit /etc/X11/xorg.conf.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Also, you can configure the mouse (and scroll) using MCC.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67

    Logitech First Wheel Mouse - Scroll Not Working

    Thanks guys! The url @ www.google.com/linux was a great help. Didn't know it existed!

    Have a happy day!

  6. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4
    I'm having exactly the same problem, and haven't been able to figure it out. I'm brand new to linux, so I'm kinda stabbing in the dark (I know the basics of UNIX under MacOS X, so I'm not totally hopeless).

    What config details did you put in the file? It was /etc/X11/xorg.conf right?

    Running Mandrake 10.1 PPC on a G4 iBook, mouse is a basic Logitech USB cheap and nasty thing (it's just called "Optical Mouse"). Like frazelle, the other buttons work fine.

  7. #6
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Uh, i think the revelent lines are

    IMP/S2
    and
    ZAxisMapping "4 5"

    i'm just working w/o the scroll for the time being,...

    sigh
    like i mentioned in another post, can't for the life of me understand why something as simple as a blinkin' mouse can't be properly detected automatically on such a polished version of Linux...
    Anyway, Have a nice day!!!

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4
    Under MacOS X I could live without the scroll (and have done so since I got rid of my last scroll mouse in favor of apple's nice simple one button mouse about 2 years ago (I just bought this mouse yesterday)), but linux's UI isn't as well designed, so it's not practicle. Under OS X I usually just slam the mouse to the right edge of the screen, click and drag. But linux has that border around the window, so it doesn't work (can you get rid of both the border and the resize-on-all-edges behavior?).

    Thanks for your help, but it's still not working. Here's what I have in /etc/X11/xorg.conf:
    Code:
    Section "InputDevice"
       Identifier "Mouse1"
       Driver "mouse"
       Option "Protocol" "IMP/S2"
       Option "Device" "/dev/mouse"
       Option "Buttons" "5"
       Option "ZAxisMapping "4 5"
    EndSection
    Is that correct? Maybe there's something else wrong?

  9. #8
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    That what i got, except i have Buttons = 3. Don know what else to say. i'm just going to keep checking the forums every once in a while to see if an answer pops up...
    Have a nice evening down there in beautiful Australia!

  10. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4
    From what I understand, button 4 and 5 are scroll up/down. Try changing yours to 5, maybe at least one of us will have a working scroll wheel!

  11. #10
    Just Joined! frazelle09's Avatar
    Join Date
    Dec 2004
    Location
    Mexicali, Baja California, Mexico
    Posts
    67
    Sounds like a great idea. Who knows, maybe it'll work... Will try it tomorrow when i get a chance. Have a nice evening!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •