Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I installed Linux a long time ago on the same computer as Windows, and after some trouble getting both to work, had a friend who also knows little about Linux, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6

    Cannot Login to Mandrake Linux


    I installed Linux a long time ago on the same computer as Windows, and after some trouble getting both to work, had a friend who also knows little about Linux, help re-install it. It seemed to work at the time, but I haven't been on it for a few months and now when I boot, I select my username (the only one there), and when I try the password I'm sure I created, the login box jumps a little and the password line is cleared. No message comes up. Is this what's meant to happen when the wrong password is entered? Is there any way I can enter Linux regardless?

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    1st make sure you've entered the pass correctly, (case sentive)
    try booting as ROOT since, if you forgot our user pass, you'll be able to change it as root.
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    How do I boot as root?

  4. #4
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    type in the USER : root
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    The problem is, I have a GUI interface and no option to type in anything - as soon as I boot, there's simply a login box with my username in it and no other options I can select.

  6. #6
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    well... you could KILL the process by doing
    Code:
    bckspace-alt-ctrl
    this will kill te X server.

    from terminal, you could type root in the login area type your pass
    and when your logued in as root, type in
    Code:
    startx
    in GUI, cant you change your userName for another one? (ex: root)
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    in GUI, cant you change your userName for another one? (ex: root)
    Not in mine it seems, although I think it looked different originally. I tried pressing backspace-alt-ctrl in every stage of booting, including when the login box is displayed, but all that happens is the screen goes black for a moment and then returns to how it was. The only option I have in the login box is to click on my username, and no password I type in, with or without caps, including no password at all, has any result besides the shaking of the login box.

  8. #8
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    I think
    you can just hold down the shift key at boot (unfortunately on my
    machine I have to actually press it repeatedly just as lilo gets
    started; holding it down doesn't seem to work), and when you get the
    "lilo:" prompt, type "linux single". This will boot linux in single
    user mode, without launching X (I hope)
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  9. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    Neither pressing nor holding it down works for me, but this could be because windows is my default operating system - whenever I boot, I get a blue screen asking if I want to load windows or linux, and windows is the first option. Nevertheless, I've tried pressing shift both before and after this stage, but this doesn't seem to do anything, and X is started regardless.
    I'm also not sure what lilo is - does this only come up if shift is pressed?

  10. #10
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Grrr I hate not being explicit enough.... try CTRL-ALT-F1... this should get you into terminal...
    login as root...
    then type
    Code:
    passwd user
    where user is your username...
    it'll ask to type the new password
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •