Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I use Mandrake to remotely connect to an Unix X server (running a specialized program for the factory). $$ X -query 170.85.211.xxx -depth 8 Works great...nice GUI interface. These computers ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26

    Remote X screen saver....UGGGGHHH!!


    I use Mandrake to remotely connect to an Unix X server (running a specialized program for the factory).

    $$ X -query 170.85.211.xxx -depth 8

    Works great...nice GUI interface. These computers are on a factory work floor, and need to be on at all times. After about 10 minutes, the screen saver comes on. This is bad. How do I turn the screen saver off in X. Neither KDE or Gnome is installed.

    I have tried doing setterm -blank, but apparently that only works for the screensaver at the command prompt. I thought that 'xset' might do the trick, but i can't get the syntax right. Is there a configuration file i can change to turn off the X screen saver (it is just a blank screen, and the monitor does NOT go into standby, so it's not a power management issue)???? Thanks a lot

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    The xscreensaver config file is located at ~/.xscreensaver. You should be able to disable it there.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26
    I don't have that file on my computer. I only have one user...root. It's not in the home directory.
    And i just did a :

    $$ find . -name ".xscreensaver" -print

    and the search resulted in nothing. is there a specific path where this file is supposed to be.

    Also, we are also using a few Knoppix clients to connect. Knoppix won't let you edit files on the cd...so, is there a command that will actually set the screen saver to 'none'. As opposed to editing a script file.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Here's the man pages of xscreensaver. All the info you want (+more) can be found there:

    http://www.jwz.org/xscreensaver/man.html

    Good luck!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26
    I saw that, but the .xscreensaver file simply does not exist on my computers. So there HAS to be another file that is controlling the timeout.

  7. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    It may not be xscreensaver then. Do you have dpms enabled in your X config file? I believe that's the power save option. Try commenting out that line (and restarting X). Also, (from reading the above links), make sure you don't have xscreensaver starting in the .Xdefaults file.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26
    I tried the DMPS stuff....it's definitely not a power problem.

    Ok...i can't find the .Xdefaults file...(not in /home directory)
    But i did find a file in /usr/X11R6/lib/X11/XF86Config-4.eg that has a screen saver time out option in it. (Option "blank time" "10")

    This is the only place that i can find a screen saver option.
    Is there another file like this?? I know this ss option does not exist in the /etc/X11/XF86Config-4 file. Why does this differ from the one mentioned above?


    Thanks for the help jeremy

  9. #8
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Is there another file like this?? I know this ss option does not exist in the /etc/X11/XF86Config-4 file. Why does this differ from the one mentioned above?
    This I don't know. Give it the 'ol college try and see what happens. The Xdefaults file may not be in /home. Try doing the global find like you did for .xscreensaver.

    Is there any possibility that your BIOS is blanking the screen? I think in some there's the option to let the OS handle it or let the BIOS handle it. Just a thought.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  10. #9
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26
    OK...so far, that has seemed to work for my Mandrake boxes....BUT i cannot edit this stinkin file in KNoppix!!!! AAAARRRG.

    Anyone know how to trick knoppix into letting me edit this file??

    No result for .Xdefaults

    Jeremy...i checked out the bios...nuttin'.

  11. #10
    Just Joined!
    Join Date
    Nov 2004
    Posts
    26
    FYI...i the .Xdefaults file was in my /root/ folder, but has no info regarding screen saver.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •