Find the answer to your Linux question:
Results 1 to 3 of 3
hi there, Ok ive decided to make the switch from windows to linux, i chose mandrake because people recommended it for beginners, so keep in mind i just installed linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1

    ATi drivers (total linux noob)


    hi there,

    Ok ive decided to make the switch from windows to linux, i chose mandrake because people recommended it for beginners, so keep in mind i just installed linux about 30mins ago and dont know the first thing about it.

    ok specs are 3ghz p4, 512mb ddr, 9800pro and ive jjust installed mandrake 10.1, i went to ATi.com to get the linux drivers and it has a choice of all this "xfree86 version" stuff, so i downloaded that check.sh thing but couldnt figure out how to run it so i just downloaded them all, but when i try to install each different one i allways get the same error:

    "Installation failed:
    file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-4.3.0-3.14.6 conflicts with file from package libxorg-x11-6.7.0-3mdk"

    this is a clean install of mandrake 10.1 so i dont see what can possibly go wrong.

    Thanks

    EDIT: Just discovered, it does it with all stuff i try to install

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I believe the instructions at the ATI site say to use the --force option to get around this issue.

    Give it a whirl.
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    10
    I had the same trouble with my drivers. I know.. Its confusing. Luckily I found a tutorial.

    You'll want to use the below command to install the drivers and you'll need the kernel_source package installed. Load up mcc and search for kernel. Install the source.

    rpm -Uh --force <ati_package_name>.rpm
    After running this you will most likely get a message stating to go to /lib/modules/fglrx/build_mod and to ./make.sh etc etc. Do so. After all this gets done run the command fglrxconfig and configure it the way you want it. YOu will need the Horizontal and vertical sync ranges for your monitor. YOu can get these from your monitors manual. I found mine through google. Now restart and you will be presented with a login prompt instead of a X environment login. Login as root and type in the following:

    cd /etc/X11/
    touch XF86Config
    cat XF86Config-4 > XF86Config

    Creates a file called XF86Config and copies the contents of the ATI default config into it. Exit from root (Ctrl+d) and startx or kde or whatever you use. ^_^ Once it starts run fgl_glxgears and if it works - Congrats. You have just installed your drivers. Pain in the ass I know. BTW my fonts were all defaulted to a small size. You may also have to re-set your monitors resolution. Hope this little tut helps. Credits to the guy on mandrakeusers.com for posting a tutorial.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •