Find the answer to your Linux question:
Results 1 to 3 of 3
I have a soundblaster live sound card, and i also have an onboard audio. I disabled the onboard audio in my bois so i can just used my soundblaster card. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    sound problems


    I have a soundblaster live sound card, and i also have an onboard audio. I disabled the onboard audio in my bois so i can just used my soundblaster card. the problem is that linux is detecing the sound card, and it shows up in my hardware list, but i can't seem to tell it to used that one for sound, it keeps on wanting to used the onboard even tho i have disabled it. Is there a way i can tell it just to used that card. I'm pretty new to linux, so i'm really not sure just want to do. I'm using Mandrake 10.0

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I must admit that I didn't realise you could disable onboard sound in your BIOS. I don't think you need to however. I also had a similar problem the other week when I fitted a new Soundblaster Live card. You might like to check which device driver your card is linked to and also check out the troubleshooting section under the Hard-drake configuration for your card. You need to be root to do this. If you type in the right commands (definitely use the console) your system will tell you if your soundcard is bound to the right driver ...

    This can be a fiddly problem, but I believe your card will work. I would make sure you are using ALSA as your sound system, and be sure to read manuals for ALSA via your console (if you can!). There is an ALSA sound mixer (can't remember how you get into it... using Windows always confuses me!) And I found that fiddling with a few settings completely solved this for me. Hope you fix it soon. Wish I could be more specific, but the truth is after a few tweaks the soundcard just started working.

    I think it's important to realise that a problem can't always be fixed just by using your gui ...
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    The driver set up can be sorted through the control centre. Run mcc and go to the hardware configuration.

    I have an 845 intel chipset in my laptop which didn't like the mandrake 845 c/s driver. (which was obviously default).

    When you're in the control centre it should recommend alternative compatible drivers. Try the different ones, remembering to either restart the alsa service or reboot in between.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •