Find the answer to your Linux question:
Results 1 to 10 of 10
Greetings, I have decided to enter the world of Linux, going with Mandrake simply because it was available to me. However, I seem to be having a small issue. During ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    Mouse not working


    Greetings,

    I have decided to enter the world of Linux, going with Mandrake simply because it was available to me. However, I seem to be having a small issue.
    During setup, my mouse will work fine, but once installation is complete and I reboot, it will not work. I tried a USB mouse and a PS2 mouse, all to no avail.
    Has anyone come across this before, and is there a simle solution to get me rolling?

    Thanks

    S

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Have you tryed to put in the USB mouse after bootup... in the GUI
    also,
    during installation, what type of mouse did you use?
    mandrake what version?
    Have you installed any external video card driver? ATI, NVIDIA?
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    1
    Hi,
    I have the same problem, mouse works fine when installing but when booting it doesn't work anymore. I've tried to plug a USB mouse after boot-up but still, nothing worked. During install I've used a ps2 mouse. I don't have an external video card, I'm using an old ATI mach 64 2MB that works perfectly fine. I'm using Mandrake 10.1

    I hope this can help...

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    This seems to be a common problem with MDK 10.1, meaning there is most likely already an update. Have you both made sure to apply all updates to your system using MCC?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    clarification

    I tried installing with usb mouse first, and then connecting usb mouse after bootup, both times failed,
    then i went through the installation again with ps2 mouse, changing mouse settings of course, worked during installation, but not after bootup, again trying connecting after bootup.
    i have a Gforce II 64m graphics card installed, and working fine.
    I will search for an update from mandrake, oh, and i'm also using 10.1

    S

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Location
    New Zealand
    Posts
    3
    I,m having same problem will keep in touch if you fix yours I get mine fixed.

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    2
    Hello All,

    I am having the same problem, and perhaps some additional info.

    I went to /etc/X11, and modified the XF86Config-4 file, by duplicating
    modifying the input and server entries for mouse input. This seemed to work; however, the changes did not survive a power-down and reboot.
    Unfortunately... I can't recreate all the changes I had made while working on this... and so now I'm back to where I started.

    However: I believe that this probably has something with the way that X Windows is initialized during boot up. Perhaps if the proper conf file or
    parameter can be identified, this can be incorporated into the boot process?

    Sorry for the ambiguity...

    -rckeller+

  8. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    Found an answer

    I had the same problem. It looks like the root cause on my machine is that Mandrake is not linking /dev/mouse correctly to /dev/mouse0. Since I knew the mouse was working correctly with the system, I changed the following line in XF86Config:
    Code:
        Option "Device" "/dev/mouse"
    to read:
    Code:
        Option "Device" "/dev/mouse0"
    I was able to get a consistently working effect. Bear in mind, I grew up with Slackware 3 and Redhat 5 and I'm not sure how Mandrake handles this sort of thing... It may be a bad idea.

    Running Tbird 1.2G, Nvidia Geforce4 MX400, Microsoft PS/2 wheel mouse, Mandrake 10.1.

    CF

  9. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    2

    usb mouse & keyboard operation

    This is a follow-up to a previous post of mine.

    When I first power up, my USB mouse & keyboard initially work fine, until linux is fully loaded and it is time to login. Then, nothing.

    I have discovered that, by adding a USB device (one actively generating interrupts on the USB bus) the mouse & keyboard are suddenly available to me. Specifically, I've been using a Kensington bluetooth USB key. Within a few seconds of inserting this, the keyboard and mouse are available.

    Even though the USB module on my system is set to start on powerup, it seems as though this is not happening. And though one would think that a keyboard or mouse input would generate an interrupt and launch the USB module, that doesn't seem to happen. But other USB devices to. Now, I leave my bluetooth key in ... and the mouse and keyboard work just fine after powerup. I can log in!

    For what it's worth....

    -rckeller

  10. #10
    Just Joined!
    Join Date
    May 2005
    Location
    Melbourne, Australia
    Posts
    10
    I solved this problem at installation, by not accepting the default for the mouse configuration, going to: PS/2 Mouse -> Generic PS/2 Wheel Mouse.

    Doesn't take long to do the install over again.

    Now working ok.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •