Find the answer to your Linux question:
Results 1 to 3 of 3
Hello I'm perplexed as to how I can remove Mandrake 10.0 from my [WinXP Home && Pro && Mandrake 10.0] triple-boot system without vapourising the MBR. I tried doing a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

    Safely Uninstalling Mandrake 10.0 on a multi-boot system


    Hello

    I'm perplexed as to how I can remove Mandrake 10.0 from my [WinXP Home && Pro && Mandrake 10.0] triple-boot system without vapourising the MBR. I tried doing a "lilo -U /dev/sda" but that messed up my MBR real bad. I had to reinstall Mandrake 10.0 to recover my MBR.
    I know there is a thread here for removing Mandrake 10.1 with its rescue utility, but Mandrake 10.0 doesn't seem to have it.
    Formatting the ext3 drive then running "fixmbr" from the Windows XP rescue disk is very risky, and Windows informs me that my MBR might just get wiped clean, thereby losing all the partition tables.

    Any help would be greatly appreciated.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Formatting the ext3 partition is how you get rid of MDK. Running fixmbr has never, in my experience, zeroed out the partition table. You could try messing around from the recovery console that you can access via the WindowsXP install CD. You may be able to fix the mbr somehow from there (other than running fixmbr).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43
    I went ahead with a modification of your suggestion. I ran the "lilo -u /dev/sda" command and sure enough, that messed up my mbr. So I sucked it up and ran the fixmbr utility from the WinXP rescue disk, and voila! Mandrake is gone! (I still have to format the partition for my Gentoo source files though; easily done with PM)

    Thanks for the advice sarumont! :P

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •