Find the answer to your Linux question:
Results 1 to 9 of 9
Alright I have On-Board Sound and my problem is i have NO Sound. This we all know is a huge problem for any music junkie (me). Well onto what works ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    No Sound: Details Inside


    Alright I have On-Board Sound and my problem is i have NO Sound. This we all know is a huge problem for any music junkie (me). Well onto what works and what don't.

    I can put in a cd ... and the bar moves like it is playing but nothing comes out of my speakers. (not good) I know that MandrakeLinux is detecting my on-board sound because when i go into the control center i get is.

    Identification
    Vendor: ‎Intel Corp.

    Description: ‎ICH2 810 Chipset AC'97 Audio Controller

    Media class: ‎MULTIMEDIA_AUDIO

    Connection
    Bus: ‎PCI

    Bus PCI #: ‎0

    PCI device #: ‎31

    PCI function #: ‎5

    Vendor ID: ‎32902

    Device ID: ‎9285

    Sub vendor ID: ‎4219

    Sub device ID: ‎20493

    Driver
    Module: ‎i810_audio

    Alternative drivers: ‎snd-intel8x0



    I know that is the information you guys like to see. Also i made sure the Alsa sound was on in the settings panel. Now my question to you is.... What do I do to be able to play audio?

  2. #2
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    first of all dont post the same thread in 2 diffrent places!
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Have you tried going into Kmix and looking at your settings in there? Sometimes the CD slider is turned right down. Also check out
    http://alsa.opensrc.org/index.php?page=AlsaMixer

    It runs in a console and can be very effective
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    What do you want me to try on alsa mixer

    What do you want me to try on alsa mixer also im sorry about the dual post.

  5. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I'm not an expert on this as different cards have different settings + different channels. Alsa mixer runs in X, though there is a Gnome front-end available for it if you prefer a gui ...

    I think you start it by typing 'amixer' in an open console - I'm afraid you'll need to read the manual (at least scan through it until you find something useful) ...

    I got my card to work by trying all the settings I could think of, working on the principle that if you move a slider up then it'll increase the output for whatever channel isn't working. This worked for me with a Soundblaster Live card ... I would like to know if it will also work for you.

    Read this and follow it step by step
    http://alsa.opensrc.org/index.php?page=TroubleShooting
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    Hey

    What is the link for the Gnome Front end come to find out I use gnome alot. anyone? i am very bad with commands and stuff i guess you could call me a newb.

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    5

    Okay got a little fixed

    I have system sound now but audio cd's wont go any clue.

  8. #8
    Just Joined!
    Join Date
    Jan 2005
    Posts
    11
    I'm a newbie myself, but I've run into the same problem (which I haven't managed to fix, I have to admit). Through some reaserch, I found out that LInux doesn't like reading digital audio through something connected to your computer through an IDE (such as your cdrom). If you have an audio cable (they don't usually come with mobo's any more, so if you have one you're pretty lucky) and connect it from your cdrom to your mobo your sound will probabily work. The plug is usually a little tiny thing on the back of your cdrom. You'll have to look up where the other end is on your board, either online, or in your manual. If you find a way to get the digital audio going, let me know, eh? I wouldn't mind actually being able to listen to cd's on this thing.

  9. #9
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Yes, Barebones is right about the cable between mobo and cd drive. Without that you'll get nowhere either under Window$ or Linux! It's simple to install, but be careful not to touch any chips in there.

    http://www.iua.upf.es/~mdeboer/projects/alsamixergui

    for gui - not sure if this is a great front-end. Good luck.

    Also, Linux is pretty good at sound support. You will need to find which sound driver is the best for your system. You need to find which driver your system is currently using as well ...

    One quick way is this: when your system is booting, it should mention ALSA during boot time, and next to this, refer to its current sound driver. You can change this under your Harddrake settings. Just take things steady though, as you don't want to make too many changes all at once.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •