Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
After going through the steps to install glib, everything seemed to have gone through without a hitch. But when I try to compile xmms I still get an error asking ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nanaimo. BC Canada
    Posts
    28

    I installed Glib but I can't find it.


    After going through the steps to install glib, everything seemed to have gone through without a hitch. But when I try to compile xmms I still get an error asking me to install glib. Does anyone know whats going on?

    checking for GLIB - version >= 1.2.2... no
    *** The glib-config script installed by GLIB could not be found
    *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GLIB_CONFIG environment variable to the
    *** full path to glib-config.
    configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
    [max420@localhost xmms-1.2.10]$

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    perhaps the glib you installed was too old?
    Make sure that you installed Glib version 1.2.2 or better.
    -lakerdonald

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nanaimo. BC Canada
    Posts
    28
    I installed 2.6.1 so its definatly not too old. Its the latest version from the website.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Did you compile from source or use an rpm?

  6. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nanaimo. BC Canada
    Posts
    28
    I am compiling from source code. If you know of a glip RPM i'd love to have that instead.

  7. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    try searching http://rpm.pbone.net

  8. #7
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nanaimo. BC Canada
    Posts
    28
    Will an RPM from Mandrake 9.x or 8.x work with 10?

  9. #8
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    hopefully. if it doesn't the reason will be that the MDK10 packages have dependencies found in a newer version.

  10. #9
    Just Joined!
    Join Date
    Jan 2005
    Location
    Nanaimo. BC Canada
    Posts
    28
    I downloaded an RPM and ran it, and it said everything was already installed. However when I try to compile xmms, it still tellsme I need to install glib 1.2.2 or higher. I have 2.6.1 install.

  11. #10
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    what is the exact error message?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •