Find the answer to your Linux question:
Results 1 to 3 of 3
I downloaded and installed Mandrake Linux a couple of days ago, and it seems to be completely bent on giving me a ton of stupid problems. I'm really starting to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    7

    Linux Newbie, problems detecting hardware


    I downloaded and installed Mandrake Linux a couple of days ago, and it seems to be completely bent on giving me a ton of stupid problems. I'm really starting to get annoyed with it because it's like running into a brick wall whenever you try and fix anything.
    First of all, my internet won't configure right. At boot, I get the message "Bringing up interface eth0:" and the computer waits for about 15 seconds before returning with [ Failed ] and continuing to boot. When I get into the GUI, the system tray has an icon that looks like a red X and says that the network is down and must be configured. I was suprized that it didn't work because Knoppix, when I was running it to try out linux, detected and configured my internet automatically without any problem at boot. IN mandrake, I tried to configure manually using the control panel, but I have no idea what I'm doing. I know my own IP, subnet mask, and default gateway, but I'm not sure what to enter for the other stuff. Is there anywhere where I can see my cable modem's confuguration in Windows so I can copy the settings down into linux?
    Next comes the problems with anything connecting to my computer via USB. I have an external SmartMedia memory card reader. Apparently, if this device is hooked up, even DrakX won't boot and just freezes when it's preparing to enter into the install wizard. I ultimately had to run the install with the device unhooked or else my computer would lock up. Next comes my printer, which is also a USB device. When I was installing, I had it hooked up and turned on, but DrakX wouldn't detect it when I went to configure the printer. I tried to do it manually but I got nothing there either. I have a HP deskjet 3820.
    Next comes some weird soundcard problem. I have basically just an onboard Intel AC`97 which comes with a lot of computers. DrakX detects it on the install, but when booting linux, there's a spot where it says "-No Soundcard found" .... [ Failed ]. Then I find myself in a spot where I can't play or record any sound.
    I'm not sure why Mandrake is doing this, especially when it seems to be a lot more built up than distros like Knoppix which autodetect and can use almost everything right away. Is it possible that Mandrake just isn't compatible with a lot of my computer hardware but Knoppix is? If worse comes to worse, what's a good alternative linux distro for a newb like me to use? I've heard SuSE is fairly easy to use, but I couldn't find any CD ISO's besides one DVD ISO which won't work for me anyway because I have no DVD burner.

    --Sorry for the long post, but if you've read all the way up to here, thanks for your time. If you need anymore information that could possibly reveal the cause of these problems, just ask.
    --Oh, and one more thing, I really don't want to have to call my ISP and ask them for thinks like what the host name or DNS servers are because I'm pretty sure they're going to just suggest I use windows. Go figure. Anyway I can find this stuff out otherwise.

  2. #2
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    I had similar problems with MDK10 detecting and configuring my modem. As a general rule, linux modules should be the first thing to check. These are modules that the kernal loads for specific items. In my case a module that config the setserial ports was not loaded at bootup.

    I no expert in Unix. But if I remember correctly, there is a command that will list all loaded modules in the kernel. Another will tell you which ones are available and the command <modprobe> will load a module into the kernel. (use with caution) check the man page for that first.

  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I agree that Knoppix has great hardware detection - I use it sometimes (about version 3.4 I think) installed on my hard drive ... It works very well. Most people wouldn't recommend Slackware for a newbie, but I would. The installer isn't too bad, and once it's on there it's very stable - I use version 10.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •