Hello all,

I am not new to this but the problems i faced are new to me yet i m not by any mean an expert in Linux so all your help will be difinitly appreciated

First it is Mandrake 9.2 the free edition which i have installed few times before on different machines and the only problem faced was cannot creat floppy boot disk during the installation (this pblm was persistant)

the machine i'm facing pblms with now is as follows
Mother Board Asus P2B-F
HD 15 GB
CPU Intel PIII 450 MHz
RAM 256
BIOS award modular
Graphic Card 3DFX voodoo3 (3000)
Audio Creative SB Live

When tried to install mandrake 9.2 I had the error

EE PCidata module does not exist

upon searching i found it was sort of popular error
reinstalled trying different settings
problem solved by using XFree 3.3.6 insted of 4 with 3D hardware acceleration

But, during the installation i had another errors (had the same during first install too)
the errors:

mdk-menue_messages-9.2-6mdk.i586
mdkkdm-9.2-9mdk.i586
XFree86-server-4.3-23mdk.i586
with each i get the question that it cannot be installed continue anyway? so i choosed yes

when i boot i get 2 errors

interface eth0 failed
cannot write controle 3.0.0 efx

after i get the localhost login
either by logging on as a root or any user i get the same strange problem which is
the system loads but there is a difference between choosing KDE or Gnome
with KDE i only get flashes and nothing else
with Gnome i got all fine except there is no start button (the star icon)
the programs do not exist
some as calculato and paint worked fine
all others say error cannot be launched or did not find them

i also did file system integrity check and it passed fine

Perhaps I should add that

in the first time i tried logging on as root and typing startx but it freezes everytime i tried that

now i do not get graphical interface for user login
i type the user name and password then startx for the GUI to load

I also tried the su command after logging on so the $ turns to # (root@localhostuser) then typing startx command to load the GUI

Thank you all for any help you can provide