Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I sent this query to the Linux Desktop / X-Windows forum but I am stuck as no one seems to be able to tell me what the problem is. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    9

    Booting up to console instead of KDE gui


    I sent this query to the Linux Desktop / X-Windows forum but I am stuck as no one seems to be able to tell me what the problem is. I hope someone in this forum will be good enough to answer me clearly.

    i am having problems booting up to my KDE gui. I have Mandrake 9.2 installed. I can't remember exactly what I did but I downloaded some updates to try to get some video player installed (i think it was mplayer).

    Ever since then (about a week ago) whenever I boot up the computer it goes straight to the console/terminal instead of the gui. Once in the console I can't find any way to get back to my gui.

    1) I was told this was likely to be a configuration problem. I was told to login as root and type

    startx

    I did and the message it gave me was

    execve failed for /etc/X11/X (errorno 2) giving up
    xinit: no such file or directory (errorno 2) : unable to connect to X server
    xinit:no such process (error no 3):server error

    2) I was told to post the results of this command

    grep EE /var/log/XF86.0.log

    and the message which came up was

    (WW) warning, (EE) error, (NI) not immplemented, (??) unknown
    (II) loading extension MIT-SCREEN-SAVER


    3) I was also told to post the results of this command

    grep EE /etc/X11/XF86Config


    But nothing happened this time - the prompt simply reappeared again.

    4) I was also told to type the name of "wizards" like

    harddrak

    but this simply came up as no command.

    Could anyone possibly advise me how I find my way back from the Console to the gui?

    thanks


  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Seems like your X is having some issues
    try running
    Code:
    Xconfigurator
    or 
    XFree86 -configure
    This will try to setup your X server with default settings...

    Please post any error you get.
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    I agree. The other command is harddrake, not harddrak.

    /Tom

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Scotland
    Posts
    47
    I had the same problem and a friend advised typing 'drakconf' at the prompt (you need to be logged in as root I think). This opens a configuration utility which should allow you to get your GUI back up and running (worked for me anyway, but I'm only a newbie - anyone else out there advise on this?)

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    9
    Thank you to everyone who took the time to look at this and reply.

    1) I am now at work so I won't be able to act on the suggestion to type "drakconf" and get back to my gui that way - I will try that later tonight.

    2) I tried "harddrake" and nothing came up.

    3) I also tried both XConfigurator and XFree86 -configure and in each case the message was the same:

    bash: XConfigurator (or XFree86) : command not found

    4) Perhaps I could briefly go through the process I undergo when booting up.

    When I power on I eventually come to the following screen:

    Mandrake Linux release 9.2 (Firestar) for i586
    Kernel 2.4.22 - 10 mdk on an i686 / tty1

    Then I am prompted for my login

    localhost login:
    password:

    Then I am told:

    last login: Sat Jan 29 20:15:50 on vc/1
    [bisd@localhost bisd] $

    Then I login as root and I am at

    [root@localhost bisd]

    Then I start trying all the commands kindly suggested by yourselves.

    Hope this helps to make things a little clearer.

  6. #6
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Two more commands for you to try, both doing the same thing - drakx and xdrake

    The command you're looking for along with a lot of the other X server interfaces should start with 'x', so try typin x at the command line and pressing TAB to see what commands are present. Try the same with a capital X as there is case sensitivity on the CLI.

    If both of these commands are missing you probably haven't got X installed at all. Just to confirm - You are using Mandrake? All of these drak and drake commands are specific to Mandrake.

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    9
    thanks bigtomrodney

    yes i do have mandrake 9.2 installed.

  8. #8
    Just Joined!
    Join Date
    Jan 2005
    Posts
    9
    Well I am no longer sure what to do now. Do I have X installed - I think so but I am not sure. And how do I get my gui back or even install a new one?

    Well thanks bigtomrodney for suggesting typing x and then tabl - this came up with a list of commands starting with x. At least something seemed to work for which I am profoundly grateful!





    :o

    However I could not find "xdrake" or "drakx". But I did find "drakconf" which gododdin suggested - this took me to "Control Center" from which the tools available are:

    Add New Users, Auto Install, Boot Configuration, Connection Sharing, Disk partitioning, Display Configuration, Firewall, Internet, Keyboard, Mouse and Service Config.

    Which one of these am I supposed to configure? I am not sure.

    What about you UgoDeschamps, got any ideas?

    Bis[/b]

  9. #9
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    You want dsiplay configuration.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  10. #10
    Just Joined!
    Join Date
    Jan 2005
    Posts
    9
    thanks jeremy i will try that when i get home tonite

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •