Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, When trying to ./configure in Gaim directory, I get: checking for GLIB - version >= 2.0.0... *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.4. *** was found! If ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Gaim and GLib problem


    Hello,

    When trying to ./configure in Gaim directory, I get:

    checking for GLIB - version >= 2.0.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.4.
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib

    It asks for GLib 2.0... So I downloaded it, but I don't want to install until the old version is gone... How do I get rid of the old version of GLib? Will that solve my problems?

    thanks,
    -Mike

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Read the error a little more closely...pkg-config says you have 2.2.3, but you actually have 2.4.something. Uninstall 2.2.3 and then re-install the latest.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    Ok.. but that's sorta my problem..
    how do I uninstall the old glib?

    thanks,
    -Mike

  4. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    It depends on how you installed it.

    If you installed it from source, there's not much you can do. If you used your package-manager, then you should be able to uninstall it.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •