Find the answer to your Linux question:
Results 1 to 3 of 3
I'm hoping that this is something simple that I'm overlooking. I logged on as joe_user and downloaded and extracted version 3.75 to that user's home directory (within X). I opened ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    nmap new version can't run as root


    I'm hoping that this is something simple that I'm overlooking.
    I logged on as joe_user and downloaded and extracted version 3.75 to that user's home directory (within X). I opened a terminal and su'd to root, entered that directory and ran ./configure && make && make install. I didn't get any errors on install and thought everything was good...except;

    When I run nmapfe (or nmap) as that user, I have version 3.75, but limited permissions - when I run the same as root, I'm still at v3.50 with full rights.

    root owns /usr/bin/nmap and nmapfe:

    Any ideas or suggestions would be most welcome.

    Cheers!

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Try running /usr/local/bin/nmap as root I think then it will be version 3.75 root might be picking the old version.

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    It doesn't strike me as correct that you were able to make install as a user. Are you sure about that? It seems that wherever the make install put your new nmap is in root's $PATH after /usr/bin/nmap (or wherever the 3.5 binary lives). Check what Giro suggested and try running a make install as root.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •