Find the answer to your Linux question:
Results 1 to 9 of 9
I have Mandrake 10.1 with KDE. I was in the configuration section, messing with screen resolution and was prompted that i must log out for the changes to take effect. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    68

    Help I messed up my Linux


    I have Mandrake 10.1 with KDE. I was in the configuration section, messing with screen resolution and was prompted that i must log out for the changes to take effect. I thought I logged out, got stuck, and restarted the X server session?, and restarted the computer. Now when I start the computer, it comes up to my login/password screen, and then logs me on as the root user. At least I think that is what it does since the $ preceeds the prompt. I have no idea how to get it to keep going. How do I get Linux to come back up automaticly? Did I mess something up with the autologin deal? HELP. Thanks

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Location
    Purdue University
    Posts
    1

    Same problem

    Something very similar happened to me. I was installing Nvidia drivers, and it asked me to reboot and now just goes to the terminal prompt. Any help for either of us would be appreciated. I have a computer engineer next door looking at it, so if he helps me out I'll post what he does.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Portugal
    Posts
    3

    ... no the help you expected

    ... but $ is for regular users and # is for root (I have Mandrake too).

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Location
    south of France
    Posts
    2
    why don't you type : start x
    This should launch the graphical interface

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    solution

    I had this problem too.
    Cause is that kernel module nvidia was not loaded.
    Adding text nvidia to /etc/modules and to /etc/modules.preload fixed this problem

  6. #6
    Banned
    Join Date
    Jul 2004
    Posts
    947
    i think your problem is with the x86 files
    have you got a live cd of any disrto's?
    cos that would make it easier for me to explain

  7. #7
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    tom boucher,
    If ever you change a config option and then the system is borked, you can simply change back to the old configuration. Try loging in at the prompt you get when you start. su to root, then go the /etc/X11 directory. There should be a file called Xorg.conf that is a sym link to something like xf86conf-4 or something close to that. There should also be one called xf86conf-4.bak or maybe .old.

    Code:
    mv xf86conf-4 xf86conf-4.backup
    mv xf86conf-4.bak xf86conf-4
    This will rename the borked one to something different, and move the old one (that workded) over the borked one. You should then be able to startx agian.

    Let me know if that works,
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #8
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by jeremy1701
    tom boucher,

    Code:
    mv xf86conf-4 xf86conf-4.backup
    mv xf86conf-4.bak xf86conf-4
    This will rename the borked one to something different, and move the old one (that workded) over the borked one. You should then be able to startx agian.

    Let me know if that works,
    Jeremy
    Great advice, but instead of the mv option use cp. If you use mv it will delete the backup and overight the original borked file. If you use cp it will over right the borked file and the original backup will still be there for the next time it happens.
    Code:
    cp xf86conf-4 xf86conf-4.backup
    cp xf86conf-4.bak xf86conf-4
    mv = move
    cp = copy

    *Sorry Jeremy, didn't want to step on your toes, but I thought it was worth mentioning.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  9. #9
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    *Sorry Jeremy, didn't want to step on your toes, but I thought it was worth mentioning.
    Dude, no worries. It's an excellent idea!

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •