Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
First, run ldconfig. Maybe that will fix it. If not, try this ldd /sbin/lilo That should tell you if and where it's not finding any libs it needs. If you'r ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796

    First, run ldconfig. Maybe that will fix it. If not, try this
    ldd /sbin/lilo
    That should tell you if and where it's not finding any libs it needs. If you'r / and /usr are on different partitions, make sure /usr is mounted and check it again. If it's still not finding everything, then check /lib, /usr/lib, /usr/local/lib, and wherever else you might have stashed some libraries for whatever it's missing, and make sure all these paths are in /etc/ld.so.conf. Then run ldconfig again and try running lilo again. Hopefully all that will work.

  2. #12
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14
    Ok i tried 'ldconfig' and got the no such file or directory message. I checked the path and no ld.so.conf exists there.

    I am booting from a rescue disk but it appears that the root it gives me is not the root of my drive. It looks like some type of RAM shell that allows me access to basic tools.

    If i mount my hdb1 like this:
    mount -t ext3 /dev/hdb1 /mnt/disk
    and then check inside /mnt/disk, the lilo and /etc/ld.so.conf are there !!

    I tried typing:
    vi /mnt/disk/etc/ld.so.conf
    and got a message saying i was denied access.

    Does this shed any more light on the subject? Sorry about my noobiness, but i catch on quick so bear with me.

  3. #13
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14

    Solved

    OK i found the problem.

    The BIOS was not picking up the second hard drive. I went into the bios and and changed a setting to auto detect drive and next boot i was looking at lilo.

    Hope someone else with the same problem reads this and looks at their bios first before spending 2 weeks trouble shooting. At least i learnt a whole lot in the process.

    *places his hands behind his back and look timidly at the ground, circling one toe in the dirt he says*

    Thanks to those people that helped me. Sorry i didnt look at the obvious before i accosted you all.

  4. #14
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    Well I'm glad you got your problem fixed. In the future, if you're booting from a rescue disk which has it's own root (most of em do anyway), then just mount your normal root on the hard drive and chroot to it, then you can access it kinda like you booted from it.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •