Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I am trying to configure my program before installations, and I am getting an error near the end, not allowing me to continue and 'make.' Code: checking for Qt... configure: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173

    Problem during configure


    I am trying to configure my program before installations, and I am getting an error near the end, not allowing me to continue and 'make.'

    Code:
    checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation! For more details about this problem, look at the end of config.log.
    Is there some place to specify where the headers and libraries are? This is new to me so there may be lack of information here. Just ask and I'll get what I can.

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Are you trying to install SuperKaramba?

    anyways, QT is what you need, you can find the rpm Here for your distro. You need QT and QT-DEVEL probably

    both can be found on that site.
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    They should also be on your CDs/DVD.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    I'm trying to install FSM (it a state machine-to-VHDL software). Thanks for the link. I'll give it a shot.

  6. #5
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    I searched. Should I get qt-3.3.4-2.i386.rpm and qt-3.3.4-2.src.rpm?

  7. #6
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Quote Originally Posted by tristanlee85
    I searched. Should I get qt-3.3.4-2.i386.rpm and qt-3.3.4-2.src.rpm?
    i386 is fine
    Unless you want to recompile from src, get the i386
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  8. #7
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    Code:
    [root@localhost tmp]# rpm -i qt-3.3.4-2.i386.rpm 
    error: failed dependencies:
    	/etc/ld.so.conf.d is needed by qt-3.3.4-2
    	fontconfig >= 2.0 is needed by qt-3.3.4-2
    	libXcursor.so.1   is needed by qt-3.3.4-2
    	libXft.so.2   is needed by qt-3.3.4-2
    	libXinerama.so.1   is needed by qt-3.3.4-2
    	libXrandr.so.2   is needed by qt-3.3.4-2
    	libc.so.6(GLIBC_2.3)   is needed by qt-3.3.4-2
    	libfontconfig.so.1   is needed by qt-3.3.4-2
    	libpng12.so.0   is needed by qt-3.3.4-2
    	libpthread.so.0(GLIBC_2.3.2)   is needed by qt-3.3.4-2
    	libstdc++.so.6   is needed by qt-3.3.4-2
    	libstdc++.so.6(CXXABI_1.3)   is needed by qt-3.3.4-2
    	libstdc++.so.6(GLIBCXX_3.4)   is needed by qt-3.3.4-2

  9. #8
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Welcome tristanlee85 to what is known as 'dependacy hell', qt which you are installing needs all the programs listed to install, now you must download these programs to install qt, so you can install FSM, look for them at www.rpmfind.net

    hope htis helps;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  10. #9
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    Since you've found the package on rpmfind, it already list the "required" package for the one your trying to install... Make sure you actually have all of them installed otherwise you'll get this nice little error about dependancie
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  11. #10
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    So, while trying to download all of the other packages needed, I can't get those to install either. I tried 'fontconfig' but it said it needed the library. So, I downloaded 'libfontconfig' and it said it needed 'Glibc' so I tried installing that and it says it needs 'rpm, sash, ldconfig, initscripts'. Is there a way to do this from the CD? I've got nothing accomplished. You guys are being great with the help. It seems I'm having more troubles though.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •