Find the answer to your Linux question:
Results 1 to 3 of 3
Could someone help me with my problem? I downloaded Bison 2.0 package and I can't install it. Configuring it goes well (as much as I can see), but after "make" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    Problem Installing Bison 2.0


    Could someone help me with my problem?
    I downloaded Bison 2.0 package and I can't install it. Configuring it goes well (as much as I can see), but after "make" command i get an error. It looks something like this:

    make [2]: Entering directory '/usr/local/src/bison-2.0/src'
    /bin/sh ../config/ylwrap scan-skel.l .c scan-skel.c --:
    make [2]: ***[scan-skel.c] Error 1
    make [2]: Leaving directory '/usr/local/src/bison-2.0/src'
    make [2]: ***[all-recursive] Error 1

    Then I tried with older version, Bison 1.875, which gave me some other (language-related) error in file LINGUAS but when I fixed it the same error message happens. Trying to find solution, I found that there is a patch for version 1.875. Since I'm a newbie, I don't even know how to use it. I guess I have to put it in directory where I unpacked package and then run command

    patch -Np1 -i ../bison-1.875-attribute.patch

    That still doesn't solve problem with version 2.0.

    Please help me because I need Bison for installing other software. Thanks in advance.
    PS I use Mandrake 10.1, and have all needed prerequisites for Bison (I think!!)

    Ivor

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Why not just use URPMI to install bison?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2
    Jeremy,
    sorry I couldn't come earlier. I used rpm and installed it without any problem. Silly it didn't cross my mind earlier.
    Thanks for your advice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •