Find the answer to your Linux question:
Results 1 to 9 of 9
Hi everybody I have searched this forum a lot and found a lot of topics on this issue, but it has not solved my problem. I've just bought a Netgear ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6

    Netgear WG511 - again


    Hi everybody

    I have searched this forum a lot and found a lot of topics on this issue, but it has not solved my problem.

    I've just bought a Netgear WG511 v2 wireless PCMCIA card (the Taiwan edition), and I can't get it working in Mandrake 10.1

    Nothing happens when i plug in the card.
    Then I have trie lspci -v and I have one post which include Netgear:
    0d:00.0 Ethernet controller: Marvell Technology Group Ltd.: Unknown device 1faa (rev 03)
    Subsystem: Netgear: Unknown device 4e00
    Flags: 66Mhz, medium devsel, IRQ 10
    Memory at 21000000 (32-bit, non-prefetchable) [disabled] [size=64K]
    Memory at 21010000 (32-bit, non-prefetchable) [disabled] [size=64K]
    Capabilities: [40] Power Management version 2

    If you want to see the entire output I'll post it.
    cardctl status gives this:
    Socket 0:
    no card
    Socket 1:
    3.3V CardBus card
    function 0: [ready]

    And cardctl indent gives this:
    Socket 0:
    no product info available
    Socket 1:
    no product info available

    I have copied the firmware 1.0.4.3.arm from prism54.org to /usr/lib/hotplug/firmware and renamed it isl3890 (i have also tried rename it to isl3890.arm)

    With the lsmod i get this modules among others
    prism54 49148 0
    firmware_class 7232 1 prism54

    In the Mandrake Control center i can se a new ethernetcard when it is plugged in, it's not identified, and the module is unknown. I have tried running the Config tool, and found the prism54 driver in the list, but i can't get on with it.

    The card works fine in WinXP on the same laptop.

    I hope you can help me. Linux is still new to me.

    Regards Sune

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    http://www.linuxforums.org/tutorials...ial-23875.html
    That's a tutorial I wrote for yoper, but it should work on almost any distro except gentoo.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    I thought the prism54 driver was a part of the Mandrake 10.1 dist. I have read of a lot of others who got the WG511 working out of the box on Mandrake, and it's in the list of available drivers.

    The problem is that I can't do
    ifconfig eth0
    because I don't know the device number.

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Why don't you just setup a new wireless connection using Mandrake Control Center?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    When i try to do that i goes like this:

    1) I start Mandrake Control Center
    2) Go to the Hardware section. Here I can se there is a new ethernetcard when the card is plugged in, but it doesn't show the vendor and under Module it says unknown.
    3) I click on "Config tool" for the device.
    4) I select Wireless
    5) Then I don't get a list of the devices, but with no devices, only the possibility to select the driver my self.
    6) I do that, and finds the prism54 driver in the list and press Next
    7) Then I select Autoprobe and press Next.
    8) And then I end back to the list of devices, like the one at step 5 again.

  6. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    MCC>
    1. Networking
    2. New Connection
    3. Wireless
    4. Follow the rest


    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    When I use the config tool in Harddrake it's same as setting up new connection.

    So when i try to set up a new connection, the card is not listed, but I can find the drive manually, I do that and pick the prism54 driver, but when i press next i just go back to where i just came from.

    So here I am. Harddrake does regocnize it as a ethernetcard, but it can't identify it, and it doesn't get a device number assigned. Or does it maybe, how can I see that?

    Is there any way I can use the new connection wizard a terminal, so I can see any errors?
    Or any other idea for looking for errors?

  8. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    I've googled a little more and found these to links:

    This one saying it has to be WG511 v2 to work:
    http://www.figuiere.net/hub/blog/?20...dapter-warning
    > I'm gonna have to find a Made in Taiwan also know as v2. The friends on #prism54 did
    > confirm this.

    And this one saying that v2 does not work (it has to be v1):
    http://article.gmane.org/gmane.linux...r.general/3979
    > (I've tried a netgear WG511 cardbus card without problem
    > with the prism54 module and I decided to buy one, but I've received a
    > netgear WG511v2 which is not supported by the prism54 module)

    Anyone who can confirm/disprove this?

  9. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    I've just found this:

    http://www.gawth.com/index.cgi/Clien...rs_2f802_2e11g

    Saying thar the v2 uses a Marvel chipset and not the prism54 like the v1. I think that settles it.

    I'm so f... tired of this wireless cards. This is the second one I bought to get it working in linux. Anyone have a nother suggesten to a card that is 110% supported in Linux?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •