Find the answer to your Linux question:
Results 1 to 4 of 4
hi i installed mandrake 10.1 a few days back and am still unable it to detect my modem.modem details are as follows: Motorola SM56 56k Internal modem i downloaded the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    cant setup dialup connection in mandrake


    hi
    i installed mandrake 10.1 a few days back and am still unable it to detect my modem.modem details are as follows:

    Motorola SM56 56k Internal modem

    i downloaded the driver from www.sm56.tk but dont know how to install it....
    i have a local dialup connection with only a username,password and a number to connect to....

    cud sumone pls help.

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Location
    Mexico
    Posts
    35
    You can start reading this tutorial: http://www.linuxforums.org/tutorials...rial-3100.html
    your modem may come with the lucent chipset if that's the case follow the instructions, other models come with the smartlink chipset a driver may be found at http://www.smlink.com/main/index1.php?ln=en&main_id=32
    a good utility to help you find out the kind of modem you have is here
    http://linmodems.technion.ac.il/
    I hope you can get it working

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    thanks a lot for the links ......i'll try out the tutorials and post the outcome asap...
    more helps and links welcome......

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    tried out everything given in the links and tutorials....but to no avail !!!

    posting more info on modem ::
    i ran scanModem utility and this was the following info it showed :


    DO use the following line as the email Subject Line, to alert cogent experts:
    scanModem, Mandrakelinux release
    Kernel 2.6.8.1-12mdk kernel 2.6.8.1-12mdk
    Occassionally reponses are blocked by an Internet Providers mail filters.
    So do in a day also check the Archived responses at DISCUSS@linmodems.org
    Code updated on: 2005_Feb_ 10
    ------------ -------------- System information ------------------------
    Mandrakelinux release 10.1 (Official) for i586
    Kernel 2.6.8.1-12mdk on an i686 /
    on System with processor: i686
    currently under kernel: 2.6.8.1-12mdk
    The kernel was assembled with compiler: 3.4.1
    with current System compiler GCC=3.4.1
    /usr/bin/gcc -> /etc/alternatives/gcc

    Checking for kernel-headers needed for compiling.
    Kernel-header resources are not evident.
    Within your Linux distributions resources, search for package names with:
    linux-headers-2.6.8.1-12mdk
    kernel-source-2.6.8.1-12mdk
    linux-2.6.8.1-12mdk
    One of which must be installed if compiling drivers to match kernel 2.6.8.1-12mdk proves necessary.
    This is necessary for most modem drivers, through some Linux distributions provide some compiled drivers.
    Within the output Modem/ folder, read CompilingDrivers.txt for details.


    Modem symbolic link is: /dev/modem -> /dev/sm56
    Checking for /dev/tts/ devices
    total 0
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 0 -> ../ttyS0
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 1 -> ../ttyS1
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 2 -> ../ttyS2
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 3 -> ../ttyS3
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 4 -> ../ttyS4
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 5 -> ../ttyS5
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 6 -> ../ttyS6
    lrwxrwxrwx 1 root root 8 Feb 19 00:39 7 -> ../ttyS7
    Checking for USB modems
    None found
    -------------------------------------------------------------------------


    when i ran the scanModem utility from the konsol it said:

    [shivaas@localhost shivaas]$ ./scanModem

    UPDATE=2005_Feb_ 10
    ONLY use scanModem downloaded as: http://linmodems.technion.ac.il/packages/scanModem.gz

    ./scanModem should ONLY be run within a Linux/UNIX partition.
    If within a MicroSoft/DOS partition, abort with Ctrl-C now !!!
    Copy scanModem.gz to your Linux partition and restart.
    +----------------------------------------------+
    | WARNING: lspci not found - exiting |
    | Please install the package: pciutils |
    +----------------------------------------------+



    the scanModem file was stored in the home directory in linux !!
    i dont know which chipset my modem uses,Lucent or Smartlink or whatnot !!
    one more thing which i noticed was that in 1 of the tutorials mentioned above,it said to run wvdial or /etc/wvdial.conf from the konsole to dialup the connection....but there was no such file present anywhere on my linux system....searched every folder !!!
    need more help....plss....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •