Find the answer to your Linux question:
Results 1 to 3 of 3
mandrake 10.1, has 2 nics, one on 192.168.1.x other 192.168.0.x .1.x is the nic setup for internet access, the 0.x is for internal lan. my xp box on the 0.x ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    53

    unable to connect to samba server


    mandrake 10.1, has 2 nics, one on 192.168.1.x other 192.168.0.x .1.x is the nic setup for internet access, the 0.x is for internal lan. my xp box on the 0.x subnet can get on the internet, do whatever, even have shorewall forwarding ports to get to my xp box from the outside world. from the xp box should I be able to ping the 0.x nic on the linux box (the lan nic) cause all I get is destination host unreachable.

    do those ping results have anything to do with the reason I get, is not accesible, you might no have persmissions to use this network resource etc when trying to access the linux box via samba? I can see the samba server from my xp box.. just cannot access it. I went through the smb.conf file.. I think its all right.. any ideas what may be going on?

    thanks

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    shorewall gave me headaches for this as well. when i enabled the pass through for Samba, it still wouldn't allow me to use it. my setup contains a Win2003 server for authentication and DNS, so i turned on Winbind and made my samba machine use kerberos authentication to connect to the win2003 server. Everything worked until i turned on shorewall. i enabled the ports for kerberos, and still nothing. try disabling shorewall (momentarily!)and see if you can get to the samba shares. if you can, then you may need to open the ports manually in the shorewall app. also, there is a ICMP return request setting you can enable/disable in shorewall, ie PING. check to see if its enabled as well. if its set to disallow ping requests, that will be why you can't ping it successfully.

    still new to linux as well, so take this with a grain of salt. happy hunting!

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    53
    ahhh thank you! you rule hehe I totally did not think of shorewall blocking it. by default shorewall has /usr/share/shorewall/action.DropSMB action.RejectSMB comment out the drop and reject lines in those files.. and add the ACCEPT lines in the /etc/shorewall/rules for the ports and works perfect now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •