Find the answer to your Linux question:
Results 1 to 5 of 5
I have scoured the net for something to point me in the right direction on this one, and have come up blank. Note that i am not a c programmer ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    Mandrake 10.1 and firefox.


    I have scoured the net for something to point me in the right direction on this one, and have come up blank. Note that i am not a c programmer in the following!

    i have a laptop with 10.1 on it, got madwifi working with no problems, and had firefox installed and working for several days. i updated my packages online using the update utility, and firefox (+ thunderbird) quit working. i removed the folders, and attempted to reinstall it. i have redownloaded it and attempted to reinstall it several times, using both the installer method and the plain old tar.gz file sans the installer. i get three lines of errors when i try it either way. something to the effect of invalid pointers and hex addresses. i tried updating to the newest bash, newest gcc, etc, and no luck.

    anybody have any ideas? thanks in advance!

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Can you run one of them (preferably Firefox) from a terminal and post the error(s) that it spews into stdout?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Also, can you run ff as a different user?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    sure thing. the three lines i get using the non GUI installer:
    SCIM: im_module_init
    free(): invalid pointer 0x8a9ebd0!
    free(): invalid pointer 0x8a9eba8!

    i then have to ctrl-c out to get back to a prompt. i have waited for up to 20 minutes before to see if it would spit out more info and return me to a prompt, but it seems like it is hung.

    when i run the installer version (gui) i get :
    SCIM: im_module_init
    free(): invalid pointer 0x820f160!
    free(): invalid pointer 0x820f138!
    ./firefox-installer: line 56: 4551 segmentation fault (core dumped) ./${BINNAME}-bin $@

    this one returns me to the prompt after getting the errors.

    Jeremy : i have tried running it both under root and under my user name. i get the same errors.

    thankyou both for the quick replies and thank you for the help!

  5. #5
    hal
    hal is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    69

    scim issue with firefox and similars

    i finaly got it working. the way i did it may not be suitable for everybody, specially if you realy need to use SCIM:
    1. unistall SCIM: $urpme scim
    2. add the following line to your $HOME/.bashrc: export GTK_IM_MODULE=xim
    3. type bash and start fox.

    this will make xim the default input method so scim won't cause any more troubles.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •