Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everybody, I am a Linux newbie but I am very interested in learning more. Recently I installed Mandrake 9.1 for PPC and the whole installation went without problems. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Sarajevo / Bosnia and Herzegovina
    Posts
    7

    How to boot into Mandrake Linux 9.1 PPC graphical mode ???


    Hi everybody,

    I am a Linux newbie but I am very interested in learning more. Recently I installed Mandrake 9.1 for PPC and the whole installation went without problems. But when the moment of the first reboot (after the installation) came and when I expected the graphical interface (XFree86 4.3.0) to load nothing happened. The system just stayed in the bash/shell and that was it. I can log in and out in the shell but I don't know how to load the graphical inteface. I tried to reconfigure the settings with the command XFdrake and changed the VGA card and monitor type and the like but nothing helped. Then I tried to run the XFree86 command to test it and I received error. I can't exactly recall what error I received but it was something with the "screen". It sad that there are enough screens but none of them has the right/appropriate configuration. And something with the crash of XFree server.

    I also noticed that my system chooses the VGA driver for the ATI Mach64 VT card but I have VT2 card integrated. But there is no VT2 driver on the list to choose from. Can that be a problem ?

    Can someone please help me with this one ?

    Thank you very much in advance.

    Edin

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Try the command
    Code:
    startx
    If that works you should edit the line
    id:3:initdefault:
    in your /etc/inittab with
    id:5:initdefault:
    .

    I hope this helps;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Sarajevo / Bosnia and Herzegovina
    Posts
    7
    OK, I'll try that. The computer is on my workplace so it will have to wait till monday.

    Thank you very much.


    Edin

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Location
    Sarajevo / Bosnia and Herzegovina
    Posts
    7

    Problem not solved yet...

    Hi guys,

    I still can't enter the graphical mode. I tried with "startx" but it didnt help. I received the same error message as with "Xfree86" command.

    I obviously have some problems with the configuration of the "XFree86". I opened the log file "/var/log/XFree86.0.log" to see what is in there and it seems that my problem lies in monitor configuration.

    Here is the complete message which I receive when I try to enter the graphical mode with "startx":


    Writing authority file /home/edin/ .xauthority
    XFree86 version 4.3.0
    Release date: 27 february 2003
    X Protocol version 11, revision 0, release 6.6
    Build operating system: Linux 2.4.19-19mdk ppc (ELF)
    Build date: 13 march 2003
    Before reporting problems, check http://www.XFree86.org
    to make sure that you have the latest version

    Module loader present.
    Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (ww) warning, (EE) error, (NI) not implemented, (??) unknown.

    (==) log file: "/var/log/XFree86.0.log",
    Time: Mon Sep 10 11:22:10 1956

    (==) using config file: "/etc/x11/XF86config-4"
    using VT7
    (EE) Screen(s) found, but none have a usable configuration
    Fatal server error: no screens found

    XIO: fatal IO error 104 (connection reset by peer)
    on X server ":0.0" after 0 requests
    (0 known processed) with 0 events remaining.




    That is the error message I receive. Also what I found very strange in the /var/log/XFree86.0.log" file is that the system recognizes various monitor resolutions but it states that none of them is usable. It is a small Belinea 14" monitor (Model 102010). Linux correctly recognizes this monitor and also its horizontal and vertical frequency. (I mean the values are not set too high or beyond the specification) but still none of the possible resolutions work.


    OK guys, you are definitely greater experts than I am, so every possible help would be really greatly appreciated. Thank you very much in advance.


    Edin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •