Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
Hi, I have a share on my XP box and can view the files and folders within it from Linux. When I try to copy the files to my Linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6

    Permissions


    Hi,

    I have a share on my XP box and can view the files and folders within it from Linux. When I try to copy the files to my Linux box I get a prompt for my username and password. Entering my correct u and p does not work. The prompt just keeps coming back. I have no trouble from my other windows machines. Any ideas?

    Thanks!

    Matt[/img]

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    What version of windows are you running? Check the share permissions in windows to make sure that the access is set for everyone and not for authenticated users or something similar.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    The computer I am trying to access is running XP Home (SP2).

    I am right clicking on the folder and selecting 'Sharing and security..."
    I then select the checkbox to share the folder and another checkbox to allow users to change files
    I looked around for the 'Everyone' setting but did not see it...I think that is in other windows versions

    Thanks!

    Matt

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    I logged in as root on the Linux box and it worked fine. Why is this?

  5. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    So what you are saying is that, you logged in as root and you could see the windows part and not have to enter the user name and password to access the windows part.

    Ok, if you can see the windows part as root, then all you need to do is to edit your /etc/fstab file as root in order for users to mount and unmount the windows partition.

    Search the fstab file for something similar to this:
    /dev/hda1 /mnt/windows ntfs umask=0,user,noauto,ro,exec,users 0 0

    Note for you windows may not be on hda1, or youmay not be using the ntfs file system. if you are not using ntfs for windows, change the ntfs part to vfat.

    The users entry will allow for any user of your PC to mount the windows partition.

    Also if you are using ntfs, DO NOT change the ro in the above line to rw. This may corrupt the windows installation and you could lose all your data. NTFS write support is still under production.

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    6
    yes, I just logged in as root and I could copy the files on the XP machine. I will give the other stuff a try.

    Thanks!

    Matt

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5
    If it's a Windoze share why does one have to worry if the drive is NTFS? Isn't Windoze itself writing to the disk and it certainly knows how to handle NTFS. I can understand leaving it ro for a dual boot situation, but is that still required over a samba share?

    Cheers

  8. #8
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71

    permissions

    I have recently installed Mdk version 10.1(?lateststable) as a triple boot winxp home, winXp proSp1a ,mandrake, on my athlon xp box. Fat 32 fs on windows and ext2(?) on nix.
    i have another box which runs xp home and shares the adsl connection on this one (though not on mandrake yet, that's the next prob I will deal with).
    I have been having difficulty accessing the windows partitions as a user, I have no difficulties seeing the partitions and accessing them as root. I have tried to change the ownership( and just permissions), as root, of the folders where I have some shared music,
    Anyway, the problem is, when I try to change the permissions as root on this folder ( and part.) I get a message which tells me I do not have sufficient access to the folder.
    I have looked at the line indicated above in /etc/fstab
    /dev/hda1 /mnt/windows ntfs umask=0,user,noauto,ro,exec,users 0 0
    I have found a line which is similar, but not quite, this is the contents of fstab:
    /dev/hdb8 / ext2 defaults 1 1
    /dev/hdc /mnt/cdrom auto user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
    /dev/hdd /mnt/cdrom2 auto user,iocharset=iso8859-15,codepage=850,noauto,ro,exec,users 0 0
    /dev/fd0 /mnt/floppy auto user,iocharset=iso8859-15,sync,codepage=850,noauto,exec,users 0 0
    /dev/hda1 /mnt/win_c vfat iocharset=iso8859-15,codepage=850 0 0
    /dev/hdb5 /mnt/win_c2 vfat iocharset=iso8859-15,codepage=850 0 0
    /dev/hda5 /mnt/win_d vfat iocharset=iso8859-15,codepage=850 0 0
    /dev/hdb6 /mnt/win_d2 vfat iocharset=iso8859-15,codepage=850 0 0
    /dev/hda6 /mnt/win_e vfat iocharset=iso8859-15,codepage=850 0 0
    /dev/hdb7 /mnt/win_e2 vfat iocharset=iso8859-15,codepage=850 0 0
    none /proc proc defaults 0 0
    /dev/hdb9 /usr ext2 defaults 1 2
    /dev/hdb2 swap swap defaults 0 0
    I know I know that's a whole load of partitions but the drives add up to 160 gb!
    The partition I want to access is win_e2
    the codepage=850 entry is confusing me. What is the addition to the line that I need to make to enable all users access to the shared files?
    I have gone into xp pro and changed the shares on this folder several times to try and get it to allow me access to change ownership or permissionsas root on mdk, but to no avail. :O(
    Also is there an explanation somewhere of what the entries above mean, I feel certain that the best way to resolve any problems is understanding?
    So far most of the tutorials I have seen ( including the nvidia drivers one on this forum) seem to assume more than newbie knowledge.
    A bit of a long post for what is probably going to be a very short answer, thanks for your patience anyway

  9. #9
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Try to install smb4k and mount your Windows drives within this tool.
    Works really well in my case, and I have a few different windows boxes that I need access to form my Linux, and there is both Active Directory servers and some workgroup connected WinXP's that I connect to.

    smb4k is as far as I know distributed with MDK 10.x, however, if you wish to have the latest one you should go to http://smb4k.berlios.de/
    and download source and compile it by your self.

    There are a few tips at smb4k site, where one is that you need to set the SUID bit on "smbmnt"
    Code:
    chmod +s /usr/bin/smbmnt
    Just be carefull, do check first where your smbmount is located
    Code:
    which smbmnt
    whould give you a clue

  10. #10
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    You could also type smb://hostname in the Location field in Konqueror
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •