Find the answer to your Linux question:
Results 1 to 5 of 5
why did lilo not come up when i booted my computer back up after installing mandrakelinux? I have winxpsp2 on my computer and i've tried installing other distros and have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Huntsville, Texas
    Posts
    14

    boot manager(lilo)


    why did lilo not come up when i booted my computer back up after installing mandrakelinux? I have winxpsp2 on my computer and i've tried installing other distros and have always seemed to have trouble with the bootloaders. I tried mepis and installed grub... but for some reason, grub kept popping up error 21. So, i gave up on mepis. Now i've tried mandrake and lilo didn't appear at ALL when i booted up my computer. Is there a reason for this? I think it has a lot to do with where lilo is located(mbr or the first part of the C: drive). When i booted up, lilo didn't come up and my computer went straight to winxpsp2. Why?! Is there anything i can do to correct this? Should i try using grub instead?

    Brian

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    uk, cambs + herts
    Posts
    34
    not to sure on this but i think
    lilo is application run form inside the grub shell
    so if grub doesn't work it doesn't matter about lilo
    the mbr will show the comp where to start if its pointing to win XP on the 2nd partition
    and you place the grub/lilo no the first partition it won't go there
    put the boot loader to the mbr unless you've got a reason not to.

    the only problem is if you mbr gets buggered up you f***ed
    but i haven't heard of it happening.


    if you give you're file system layout, pc details and install options ill give it a closer look

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Location
    New York
    Posts
    150
    Quote Originally Posted by fomhoire
    the only problem is if you mbr gets buggered up you f***ed
    I'm no boot expert, but I believe a messed up MBR is a very easy problem to fix - either pop in a windows cd and get to a command line where you can type "fixmbr", or use something like knoppix as a recovery disk to rerun the lilo command (after mounting your harddrive and copying over your normal lilo.conf).
    \"Nifty News Fifty: When news breaks, we give you the pieces.\" - Sluggy Freelance

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    bst82551, are you sure you asked it to install LiLo during the install?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #5
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    239
    You have probably installed the boot loader to a partition which the bios is not or cannot check for booting...

    So like Workaphobia said, try using a boot or live cd and re-install lilo or grub to the mbr.

    Also, you could put it on a floppy, then even if xp over-writes your mbr, you will always have a backup!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •