Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
I have been trying all day to get the nvidia drivers installed, I managed to get the driver package to run in a terminal but with the X server running, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71

    Lilo bootloader and nvidia graphics install


    I have been trying all day to get the nvidia drivers installed, I managed to get the driver package to run in a terminal but with the X server running, it of course told me it had to be shut down first. Okay I then managed to get into a non gui environment by logging off (somehow).
    I managed to run the driver package but it told me it couldn't find a compatible kernel source.
    Okaay I have installed the 2.6.8.1-12mdk package, but now I seem to be unable to boot or logoff into a non gui env. Also since running the driver package it now appears to have disappeared (as far as the terminal is concerned) it is still visible in my /home/billybeag/folder however. I have since deleted this one and downloaded it again.
    What I need to know is how do I get a terminal only(non GUI) option in the lilo loader?

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    You don't have to. If you're in a GUI environment, you can open a terminal and (as root) type:

    Code:
    init3
    or
    Code:
    telinit3
    and it'll drop you to the CLI

    You definitely need to install the kernel-source package, if you haven't already.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    I installed the enterprise one by mistake first I think which is how I ended up in a no GUI env.
    I have got the above mentioned package installed now, though I would have thought this distro 10.1 would have the latest stable kernel package already installed.
    I am probably misunderstanding something....
    oh well here goes...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    Those commands both worked fine for getting out of the GUI.
    However I cannot get that ****** file to run I keep getting a no such file or directory message, I have checked the filename and cd'ed to the correct folder but it still cannot find it.
    I even browsed to the right folder and copied the directory and filename from the address bar and then stuffed it into the terminal window to see if it would at least initialise, no luck.

    Do I need to actually be in the correct directory to run this, or is there some way I can get the terminal to find the file and run it?
    It does seem that nvidia have done their best to get this package as simple as possible, but for someone who has been supporting windows OS's for years I am really starting to feel pretty stupid.

  6. #5
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    If it's in (for example) the /root directory you could run it like:

    sh /root/nvidia-<version_numbers>

    You have to run it as root.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    LOL I just tried something else which very oddly worked.
    In a previous post on "ATI or Nvidia?" you inserted a peice of code
    Code:
    sh NVIDIA-Linux-x86-1.0-6629-pkg1.run -q
    okay this is exactly the same as I am typing in to the terminal same case etc. but my typing does not work, but if I copy/paste your code into the terminal it runs!

    Wierder than wierd

  8. #7
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Now you need to modify your xorg.conf file

    Code:
    /etc/X11/xorg.conf
    In the "device" section, specify nvidia in the "Driver" field. After that, you can "modprobe nvidia" and "startx" and have 3D acceleration enabled.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    WOW Trigger !
    I haven't actually got it to run outside of the Xserver yet. I managed to get it to run like I said but if I copy your code then go into the terminal and drop the xserver it doesn't keep the clipboard contents.
    Still trying though.

  10. #9
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Are you logging in as root at the terminal? If so, then you're starting out in the /root directory not your home directory (/home/<username>). You need to either define the whole path to the file:

    Code:
    sh /home/<username>/nvidia-<version_number>
    or go to that directory and run the script from there:

    Code:
    cd /home/<username>
    sh nvidia-<version_number>
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  11. #10
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    hmmmm
    I have actually been trying that.
    I am root while doing this and have cd'ed to the right folder.
    I must be making some kind of typo somewhere. It is odd.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •