Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Ok, I just built a new system. I installed XP Pro last week and spent several days installing software, moving backup files over to the main paritition, etc. When I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8

    FREAKING OUT!!!


    Ok, I just built a new system. I installed XP Pro last week and spent several days installing software, moving backup files over to the main paritition, etc. When I installed XP I intentionally left a 40GB partition for installing linux. I heard that would be a good thing to do... So for the past few days I've been trying to install some version of linux in that partition.

    First I tried Mepis, I just got a command prompt after logging in as root, but no idea how to start the install or gui... So then I tried Knoppix. Same result. I tried Suse 9.2, but I couldn't get anything to show up with that one... So last night I tried installing Mandrake 10.1.

    The installation seemed to be going very well. The only problem I noticed was that sometimes when I touched a key on the keyboard I would get a string of q's (i.e. qqqqqqqqqqqqqqqqqqqqqqq). It didn't happen all the time, but it was a minor annoyance. So then I got to choosing the resolution. I chose vesa as the graphic device, since it didn't list my graphic chip (Intel 915G) and a reasonable resolution. The first few resolutions I treid to test didn't work, but then I finally got one to work. I was looking at a blue screen with a big "X" cursor for my mouse. But I could NOT get out of that screen. Nothing I pressed on the keyboard would get me out of that screen. Finally I pressed the shutdown button on my pc and that ended that. I rebooted and went into Windows, just to be sure everything was working ok. It was. Whew!

    But then this morning I decided to try to re-install the Mandrake installation. I switched keyboards, since I thought that might be causing the problem, and I began the install. I had the same strange keyboard behavior, where it would insert long strings of q's all by itself. I pressed on. When I came to choosing the formatting option, I tried to select the existing partition I used before, but it kept saying it didn't exist. So finally I chose the "Use empty space" option. When I got to the bootloader options I wasn't sure which one to choose, and I remember being told that if you didn't know which option to choose, choose the default. So I did, which I believe was MBR...?

    When I finished, it asked me login, which I did (although it was very difficult with it spitting out those strings of q's, I had to be VERY fast in typing my username and pass). But then I got to a COMMAND PROMPT!!! Same as all the other distro's I've tried. I typed KDE, but it gave me an error saying the graphics I chose wouldn't work, or something to that effect. So I rebooted.

    I chose Windows on the reboot, and that's when I got the dreaded "NTLDR is missing, press ctrl+alt+delete to reboot" message. This is why I am FREAKING OUT!

    I've got tons of data on that drive that I can't lose. Pictures and video of my son, documents that I do not have a backup of. I have to get into that drive. I do have three other hard drives, so if I can get in I can back up the data, but I just don't know how. Can someone PLEASE HELP!!!???!

    I'm not sure this linux thing is for me. I've been using computers since DOS 2, so I'm no stranger to the command line, or editing configuration files, etc. But I don't know if I have the patience for this anymore... I was told that these distro's were relatively easy to install, very user-friendly. I've found the exact opposite...

    Anyways, I could REALLY use some help right now - THANKS for reading this long message... and for responding...

    Eddie

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Eddie,
    Let's just settle down here... Worst case senario, you can simply put in your win disk and reinstall the win boot loader from there, and you'll be fine.

    Now, for MDK...

    Did you have any USB devices when you installed? The second time, it sounds like you didn't setup your graphics card?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Thanks for your reassurance...

    Yes, I use a wireless mouse, which is USB. My printer is also USB, but it seemed to detect and install drivers for both of those (logitech and HP). The second time I installed I did setup the graphics card, but I did not test. So essentially I guess I did not set up the graphics card.

    -e

  4. #4
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    I think you can still run XFdrake from the CLI to reconfigure X and try to get it working.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Unfortunately you're already way over my head. I'm sure I can find out what XFdrake is, and get it to run, but how to reconfigure X is another story. I'd need a little more info, or a link to instructions...?

  6. #6
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    To get it to run, you should (as root) just be able to type in XFdrake and hit enter.

    It's a utility that will allow you to tell the system what monitor you are using, what video card, horizontal and vertical refresh rates, etc. First thing to do is make sure that it detected the correct monitor and video card.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Ah, ok. Now, I am using the graphics directly off my mobo. It's a new Intel chipset, the 915G, but I'm not sure it will show up in the configuration... Any idea what I could use if it's not listed?

    Thanks again for your help!

    eddie

  8. #8
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    As far as I know, the 2.6 kernel doesn't have support for that chip yet. You might have to throw a cheap-ass AGP or PCI card in there to get graphics in *nix.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #9
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Yeah, I was afraid of that. Maybe I'll pick one up this afternoon @ BestBuy...

  10. #10
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    I usually recommend nVidia chipsets for *nix, because their driver support is much better than ATI's.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •