Find the answer to your Linux question:
Results 1 to 7 of 7
Hey guys ! I installed a Mandrake (10.1 if I remember correctly), I wanna run a Web server, I ticked the box during the install and the server obviously runs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Posts
    14

    Web server ...


    Hey guys !

    I installed a Mandrake (10.1 if I remember correctly), I wanna run a Web server, I ticked the box during the install and the server obviously runs (when I go to localhost or my IP, in my browser, I get the page "congratulations, your web sever works ...") and I found the location of the page so I will be able to set it up right, but only as root. I would love to be able to have pages such as http://xxx.xxx.xxx.xxx/~user for my users but I don't how, a litte search on the internet made me try to install drakw which provides wizards for all those servers, but still, even if I make a directory in my /home/user I get this message :
    Code:
    Forbidden
    
    You don't have permission to access /~fanda/ on this server.
    (yes the right of the directory are fine ... : 755)

    So can anyone help ?

    Thanks a lot ^^

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    do you have a seperate user set up for visitors of your website?

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Posts
    14
    What do you mean ? I tried to reach the web server form another machine on the network and it works (i also get the congratulations stuff ...)

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    and do you get the accessed denied error from the local network too?

  5. #5
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    fanda, you have to configure your .htaccess file to let you view /~name, you might want to look here http://httpd.apache.org/docs-2.0/mis...rity_tips.html the stanza you need for letting access to /~fanda/ is
    Code:
      <Directory /usr/users/fanda/public_html>
    Order Deny,Allow
    Allow from all
    </Directory>
    i think.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #6
    Just Joined!
    Join Date
    Jun 2004
    Posts
    14
    And where am I supposed to do that ?

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Location
    In the cupboard under the stairs probably. nr Aylesbury
    Posts
    71
    In the terminal shell.
    Or you could do it in the permissions module in the MMC which is found by going to start>system>configuration>configure your computer, then choose security and click on Permissiions.
    Check the security levels too if they are set to high in basic (which they probably are if you installed with the intention of runnning an hhtpd server) thenit will try to disallow changing access rights, this is changable in the system setting i think but being a newbie too, I am a bit iffy there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •