Find the answer to your Linux question:
Results 1 to 3 of 3
How do you login as root in Mandrake 10.1? I donít know if this is a glitch in the software or if I am doing something very wrong here. To ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    BNQ
    BNQ is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Logging In As Root In Manrake 10.1?


    How do you login as root in Mandrake 10.1? I donít know if this is a glitch in the software or if I am doing something very wrong here. To begin with, Iím switching from Redhat9 to Mandrake 10.1. With redhat, you only need to type in the root name and then the password from the gui interface to login as root. With Mandrake, you get a clickable list of usernames and root is not one of them. I tried logging in from the shell as root and I get an authentication error for root. I know that my password for root is correct because when I login as a user, I can change system settings by typing in the root password which is accepted by the system. Is there something that I am missing here? or is there a glitch with this? I donít want to have to type in the root password every time that I make some kind of change or do an update. If I have to do that, Iíd just assume go back to Redhat. I installed Mandrake as a server. Any suggestions would be greatly appreciated.

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    It is a very bad idea to login as root...especially on a server. That is why root login from the graphical login manager is disabled in Mandrake (and Suse). I do not recommend logging in as root. As a matter of fact, I actively discourage it when possible.

    Again - I do NOT recommend logging in as root. Please use su or sudo.

    Having said that, it's your machine. You should be able to do it by editing /etc/kde/kdm/kdmrc and changing
    Code:
    AllowRootLogin=false
    to
    Code:
    AllowRootLogin=true
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    BNQ
    BNQ is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    Thanks for the quick reply. So obvious that it never occurred to me. I don't run the server under root. I only do setups under root. Thanks again for the solution.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •