Find the answer to your Linux question:
Results 1 to 5 of 5
ive installed and i can log in... i get [tom@localhost tom]$ when i type in startx or startkde it says xset:unable to open display xsetroot: unable to open display xmodmap: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    cant start KDE from command prompt


    ive installed and i can log in... i get [tom@localhost tom]$
    when i type in startx or startkde it says
    xset:unable to open display
    xsetroot: unable to open display
    xmodmap: unable to open display
    xmodmap: unable to open display
    startkde: Starting up...

    (magicdev:2078): Gtk-WARNING **:cannot open display:
    ksplash: cannot connect to X server
    kdeinit: Aborting. $DISPLAY is not set.
    Warning: connect() failed: : No such file or directory
    ksmserver:cannot connect to X server
    startkde:shutting down...

    PLEASE HELP!?!?!?!?!?

  2. #2
    mcm
    mcm is offline
    Just Joined!
    Join Date
    Mar 2005
    Location
    Sao Paulo - Brazil
    Posts
    59
    Try xinit instead...

    If it loads, then run startkde or kde.

    Best Wishes!

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    xinit results in another error... errno 13
    thanks for tryin

  4. $spacer_open
    $spacer_close
  5. #4
    mcm
    mcm is offline
    Just Joined!
    Join Date
    Mar 2005
    Location
    Sao Paulo - Brazil
    Posts
    59
    Have you configured X already?

  6. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Johnstown, Oh
    Posts
    3
    Can you post this section from your /etc/X11/XF86Config file:
    Section "Device"
    Identifier "device1"
    VendorName "nVidia Corp."
    BoardName "NVIDIA GeForce2 DDR (generic)"
    Driver "nv"
    Option "DPMS"
    Option "IgnoreEDID" "1"
    EndSection

    When I setup MDK 10.1 it doesn't configure this file correctly. I have to change to "Driver "nv"" instead of the pre configured "Driver "nvidia""

    Also to get my nvidia card to initialize right I have to add the line
    Option "Device" "/dev/nvidia0" then I exit out re-login and type "kde" all by itself and it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •