Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I recently installed Mandrake 10.1 as my first Linux system. I'm beginning to get to grips with it... in a n00b like way. I still haven't succeded in getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14

    USB devices not Detected


    Hi,
    I recently installed Mandrake 10.1 as my first Linux system. I'm beginning to get to grips with it... in a n00b like way. I still haven't succeded in getting my wireless USB client to work though. Although I've installed ndiswrapper it does not appear to recognise that my USB client, nor anything else plugged in through USB is actually there.

    I've attempted to run "lsusb" to ensure that it does not notice them, but this results in a command not found message... which isn't much use.

    I've looked through my Bios and ensured that the USB ports are enabled for both V1.01 and v2. They are and always were.

    It obviously recognises them in some form or other as plugging in my USB mouse causes the system to freeze while mounting the USB filesystem on bootup. I'm not sure if thats all it recognises from USBs though.

    The USB ports they are connected to are part of my GA-7N400 Pro 2 Gigabyte Motherboard.

    Cheers for your help.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14
    As a side note I'm also getting a "command not found" message from entering lsmod which I was told would give me some useful info.

    Could anyone explain why these two commands don't work? Do I need to install something thats not there?

  3. #3
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    have you tried these commands in root? In a terminal do the following:
    Code:
    su
    now enter your rootpass, then
    Code:
    lsmod
    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  4. $spacer_open
    $spacer_close
  5. #4
    mcm
    mcm is offline
    Just Joined!
    Join Date
    Mar 2005
    Location
    Sao Paulo - Brazil
    Posts
    59
    If you still get the error message, try:

    su -

    lsmod

    The difference betwen su and su - is: with the second option, you also login as root, BUT, ALL root's environment variables are also loaded. This does't happen with su.

    Hope this helps.

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    14
    Yo, cheers man, didn't realize I had to be root to use them.

    Well, I used them and heres the data I got. I think i've preety much localized the problem by looking in syslog, heres what it said:

    hub 3-0:1.1: USH hub found
    hub 3-0:1.1: 6 Ports Detected
    hub 3-3: New High Speed USB Device Detected using Address 2Control
    hub 3-3: timeout on ep0out
    ehci_hcd: 0000:00:02.2: Unlink after no IRQ? Differant ACPI or APIC settings may help.
    hub 3-3: Control timeout on ep0out
    hub 3-3: Device not accepting address 2, error - 110
    hub 3-3: New high speed USB device using address 3
    hub 3-3: Control timeout on ep0out
    hub 3-3: Control timeout on ep0out
    hub 3-3: Device not accpting address 3, error -110
    And heres what I got from lsmod

    Module Size Used by
    ndiswrapper 128116 0
    ehci_hcd 26244 0
    ohci_hcd 18468 0
    usbcore 103172 5 ndiswrapper, ehci_hcd, ohci_hcd
    What part is "usbcore" meant to represent? Anyone know?

    This is what lsusb gives me:

    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    Dmesg contains...

    ndiswrapper version 1.1 loaded(preempt=no,smp=0)
    usbcore: registered new driver ndiswrapper
    When I do "ndiswrapper -l" it gives it tells me that the driver is present but says nothing about the hardware (its meant to say the hardware is present as well)

    Anyone able to point me in a new direction?[/quote]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •