hi,
i am very new to linux. i wanted to use usb storage devices with linux. i managed to get what i wanted but havent followed what i did. please explain what i did.
i use mandrake 9.2 x86-64

here is what happened and what i did..

when i connected the external hdd for the first time b4 startup, it notified me that an a new device has been found and gave me the option of running the config tool for it.. there i specified the mount point.
i use kde gui.. once there, i mounted the device(had to do this as root only) then i couldnt read or write as a general user.
---> my problem- i watned to be able to mount the external hdd as normal user adn be able to read and write.

next i plugged a flash drive b4 boot and ran the config tool. this time it created a desktop icon for that. and i was able to read and write to it. how ever if i tried to unmount it as root, it told me that it is not mounted at all!!!!!
---> my problem - dont understadn how a device works without being mounted. but it worked neways.

so i went to /etc/fstab and added the following line hoping the achive similar result for external hdd (identified by sda1 by the system)

none /home/bhushan/exthdd supermount dev=/dev/sda1,fs=ext2:vfat,--,iocharset=iso8859-1,codepage=850,kudzu 0 0

and commented out the following
/dev/sda1 /home/bhushan/exthdd vfat umask=0 0 0


i did this because i saw that for the flash drive (which was identified as sdb1 by the system) there was this line present

none /mnt/removable supermount dev=/dev/sdb1,fs=ext2:vfat,--,kudzu,iocharset=iso8859-1,codepage=850 0 0


now i am able to plug and play both hdd and flash drive but i dont understand whats going on.. please explain.


thanks

wbr
bg