Find the answer to your Linux question:
Results 1 to 3 of 3
Firstly, all my usb devices were connected when I installed mandrake. Then linux wouldn't boot up with the usb devices connected so I removed them. When I am already in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    USB problems with Mandrake 10.1!


    Firstly, all my usb devices were connected when I installed mandrake. Then linux wouldn't boot up with the usb devices connected so I removed them. When I am already in linux and plugs in a usb device it throws an error(somthing with IRQ 21), and that's it, nothing works. My printer is also a usb printer and I installed it from mandrake's list of drivers cause it couldn't detect it(usb problem). Now my printer is installed but it keep saying my printer is disabled. I also went ad looked in my bios for the settting PNP OS, but my bios doesn't have that setting. Can somebody please tell me what to so with my usb devices and mandrake 10.1?

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Have you tried going into the Mandrake Control Center's bootloader module and setting your machine to boot with noapic (hint: you MUST click Next, etc. through to completion or your changes won't be saved)? You would have to reboot after doing so for the change to take effect.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1
    I had the identical problem with MDK 10.1 trying to get my Fuji FinePix A205 to mount, including the system message about disabling IRQ 21. After thrashing about on other forums, I found out the solution was similar to what Flatline suggested.

    I edited out the ACPI=HT in /etc/lilo.conf which disables IRQ routing. Then I ran LILO to restart and the camera mounted the first time. There is a risk of hanging the system if you have a really strange motherboard or a defective one. Have a boot CD standing by so you can re-edit the file if you hang the system.

    I also discovered that MDK 10.1 defaults to turning off DMA. You should uncomment the line in /etc/sysconfig/harddisks for DMA to turn this back on. BIG difference on tasks heavy on disk I/O.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •