Find the answer to your Linux question:
Results 1 to 3 of 3
I recently had to replace my computer due to a defective main board. I got a new computer (a x586). I re-installed the HD and BIOS at bootup showed all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146

    Grub boot problems


    I recently had to replace my computer due to a defective main board. I got a new computer (a x586). I re-installed the HD and BIOS at bootup showed all my peripherals correctly. I did re-install Linux MDK10.0 on my Linux partition but still can't boot from HD (my /home/user data is safe). My Linux Os is Mandrake 10.00 Official installed on a partition on a Quantum Fireball HD.

    On booting the comp., the Lilo bootloader screen wouldn't show up. I booted with my Mandrake Install CD and used the rescue feature to do a grub-install:
    on hda5 my bootable linux partition. (I got the following message at console:
    <<#found a mandrake root partition on /dev/hda5 type ext3 version MDK10.0 i586>> when I did did the grub install successfully, and rebooted I got this error message (after the bios detected all my peripherals successfully):
    <<grub loading stage 1.5...grub loading please wait... error5>>

    ??? could someone let me know how to get my linux to boot? I can get can a console prompt and can 'see' the contents of my HD but cannot boot from the harddisk. All the basic Unix commands are available on my bootable CDROm.

    Any help would be appreciated.

    BTWI used #drivinst loaded drivers for usb, but modules were missing for keybdev and sonypi.ko missing for the ACPI Bus Master Controller..nevertheless, lsparts# shows all my partitions (i think from fstab)..

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Error 5 is usually a "bad partition" error. Try following the Mandrake Rescue CD instructions from here and see if it works:

    http://www.linuxforums.org/tutorials...ial-19999.html
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    I tried the how/to tutorial. After carefully doing the instructions, I narrowed the problem to a missing grub.conf file. I believe that is what is generating the 'error 5' message at bootup. The boot up never reaches 'stage2'.

    After booting with the MDK CD, I did a 'chroot' to my HD root. I then activated the grub> shell prompt. After which I did the root (hdx,y) and setup (hdx) and even the kernel command. After boot I got same error message.

    In the meantime I took a look at Lilo which I was using in a dual boot setup on my old computer. When I install the lilo bootloader, it recongnizes all my partitions (including windows). But at boot, the Lilo splash screen never appears. Instead I get an error after the bios.

    SO NOW WHAT? I would like to rreinstall my lilo or grub whichever one works. COuld someone perhaps tell me why the grub.conf is missing (I searched etc/ and all other directories) Do I have to create one?

    Another question: is it possible that the MBR got corrupted?

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •