Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
I tried it twice, but what happened was different each time. 1st: ls: /etc/X11/xorg.conf: No such file or directory 2nd: /etc/X11/xorg.conf @ (By the way, thanks a bunch for all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28

    I tried it twice, but what happened was different each time.

    1st:
    ls: /etc/X11/xorg.conf: No such file or directory

    2nd:
    /etc/X11/xorg.conf@


    (By the way, thanks a bunch for all your help so far!)

  2. #12
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    did it say something like:
    /etc/X11/xorg.conf->/some/other/file/or/directory?
    if so, try the chmod on the file that it points to (the second one listed)
    otherwise, you can just write a new one, I'll post an example one for you to write up.

  3. #13
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    It did not show any other directory when I used the command.
    An example would be helpful!

  4. #14
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    try moving it somewhere else, and then editing it:
    Code:
    mv /etc/X11/xorg.conf /root/xorg.conf
    $EDITOR /root/xorg.conf
    then move it back when you're done
    also, what was the _entire_ output of 'ls -l /etc/X11/xorg.conf'

  5. #15
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    If all else fails you could just write another file, though I would like to keep that in reserve, as that may involve a lot of troubleshooting getting your paths right. Try the above suggestion first, if that fails, try this:
    Code:
    rm -f /etc/X11/xorg.conf
    cat > /etc/X11/xorg.conf << "EOF"
    # custom xorg.conf file - smindinvern 2005
    Section "Files"
        RgbPath    "/usr/lib/X11/rgb"
    
        FontPath    "/usr/share/fonts/local/"
        FontPath    "/usr/share/fonts/misc/"
        FontPath    "/usr/share/fonts/75dpi/&#58;unscaled"
        FontPath    "/usr/share/fonts/100dpi/&#58;unscaled"
        FontPath    "/usr/share/fonts/Type1/"
        FontPath    "/usr/share/fonts/TTF/"
        FontPath    "/usr/share/fonts/CID/"
        FontPath    "/usr/share/fonts/Speedo/"
        FontPath    "/usr/share/fonts/75dpi/"
        FontPath    "/usr/share/fonts/100dpi"
    
        ModulePath    "/usr/lib/modules"
        ModulePath    "/usr/lib/X11R6/modules"
    EndSection
    
    Section "Module"
        Load    "dbe"
        Load    "type1"
        Load    "freetype"
        Load    "glx"
    EndSection
    
    Section "ServerFlags"
        Option    "blank time"    "10"
        Option    "standby time"    "20"
        Option    "suspend time"    "30"
        Option    "off time"    "60"
    EndSection
    
    Section "InputDevice"
        Identifier    "Keyboard1"
        Driver    "kbd"
        Option    "AutoRepeat"    "500 5"
    EndSection
    
    Section "InputDevice"
        Identifier    "Mouse1"
        Driver    "mouse"
        Option    "Protocol"    "IMPS/2"
        Option    "Device"    "/dev/input/mice"
        Option    "ZaxisMapping"    "4 5"
    EndSection
    
    Section "Monitor"
        Identifier    "Monitor1"
        VertRefresh    "50-100" # Make sure that this is in accordance with your monitors capabilities
        HorizSync    "30-50" # same as above
        Option    "dpms"
    EndSection
    
    Sectoin "Device"
        Identifier    "Device1"
        Driver    "vesa" # or if you know the right one use it
    EndSection
    
    Section "Screen"
        Identifier    "Screen1"
        Monitor    "Monitor1"
        Device    "Device1"
        DefaultDepth    "24"
        SubSection    "Display"
            Depth    "24"
            Modes    "1024x768"
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier    "Default Layout"
        Screen 1 "Screen1"
        InputDevice "Mouse1"    "CorePointer"
        InputDevice "Keyboard1"    "CoreKeyboard"
    EndSection
    EOF
    As I said this is a last resort, and you can see why, but, if worst comes to worst, you can always try this

  6. #16
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    I'm using "xorgconfig" to re-write the file right now, but I got to the display adapter/ graphics drivers part and I am unsure which to choose, and I have tried a few but Linux fails to boot. I tried VGA, the older Intel one (14), and the newer Intel one (15) because I have on-board video. VGA should have worked because it's very general but it only goes thru. in a very low color depth, otherwise I get an error saying driver does not support it. So, I tried it in 256 colors, but... When I start it, the screen flashes for a moment, the top of the monitor turns purple for a second, then goes back, and I'd assume it failed. I get the message..

    Using vt 7
    xvt: unknown option '-n'.
    waiting for X server to shut down.

    Since I have on-board video that's pretty generic (it's not geforce onboard or anything) what do you recommend I use, and why does this still shut down? Damn you, Mandrake!

  7. #17
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    first of all, what kind of vid card do you have, second, you can open your xorg.conf file and find the device section, change the driver line to vesa, then in the screen section, make sure that these lines look like this:
    DefaultDepth "24"
    SubSection "Display"
    Depth "24"
    Modes "1024x768"
    EndSubSection

  8. #18
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    VESA worked! I'm up and running! You're my hero! *glomp*
    Time to learn me some Linux!! Can't wait until I set up a wireless network...
    Thanks a ton for walking me through this, I'm a newbie and I really didn't know what I was doing, but even getting through this has taught me a little already.
    *Goes over to his other computer and starts messing around in Linux*

  9. #19
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    sure, glad I could help I think you will find that linux does things like this occasionally, but for the most part it's really stable. But when it does goof up like this, we're always here for you. Enjoy your new linux system

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •