Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Alright, I'm up to the partitioning part of Mandrake Linux 10.1 Community setup. I decided I'm not ready to install yet, but it won't let me move backwards in instalation. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28

    Not So Simple GUI Question - Please Help!


    Alright, I'm up to the partitioning part of Mandrake Linux 10.1 Community setup. I decided I'm not ready to install yet, but it won't let me move backwards in instalation. From the "choose how to partition" page, would it be safe to shut off my computer?

    Another very quick question. What is a good way to back up Windows XP but nothing else on my harddrive? Just the basics?

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    12
    As long as you didn't write anything to the disk(s), which from what you described you shouldn't have, you should be fine turning it off. I wouldn't try that during any partitioning though.

    good luck with your mandrake

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    Thanks, I turned it off, used chkdsk, and ran defrag, and split the Windows partition successfully. I now have linux on my computer but I have a new problem. ^.^ When I installed Mandrake Linux 10.1 Community, I disabled start in GUI (or something of the likeness). So it starts in the command prompt, and I can log on by, say, typing "Bob *enter* cheese *enter*" for un/pw. So. I'm logged on, and I have no clue what to do from command prompt, seeing as I'm a newbie, and so I'll start the GUI. I head somewhere that you can type "emerge gnome" or "emerge kde" and start that x-windows GUI but it says command not found (or, once again, something of the likeness). Any help would be appreciated, and I'd really appreciate it if you could walk me through COMPLETELY step-by-step. (For example don't tell me "open this file and edit this" because seeing as I'm in command prompt I have no idea how to do that.)

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    you should have install Xwindows by default, and emerge is part of a gentoo package called portage, no other distro has it, so don't even worry about that. Once you've logged on, you can type:
    Code:
    startx
    that will bring up the gui, if you want to start up into the gui automatically, do the following:
    open /etc/inittab with kate or gedit, some gui based editor and find the line that says something like id:3:initdefault: and change the 3 to a 5, your system will now start up into gdm or kdm, whichever you have set automatically

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    Well, "startx" does not bring me to a GUI, it rather gives me a bunch of text that takes up the whole screen. I see no x-windows or Gnome or KDE or anything after "startx". Emerge Gnome and Emerge KDE still do not work after "startx".

    I looked through the text it gave me and found some interesting stuff.

    Data imcomplete in file /etc/x11/xorg.conf
    at least one Device section is required.
    (EE) Problem parsing config file
    (EE) EError parsing config file

    Fatal server error: no screens found
    XIO: fatal IO error 104 (connection reset by peer on x server ":0.0"
    After 0 requests (0 known processed) with 0 events remaining.


    EDIT: And yes, I did install both Gnome and KDE as well as EVERYTHING else that Mandrake would allow me to install.

  7. #6
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    you need to add a device monitor and screen section to your xorg.conf file, these should appear in order after the core pointer and keyboard sections. from the command line:
    Code:
    $EDITOR /etc/X11/xorg.conf
    # PGDOWN past the core pointer and keyboard sections, then insert the following:
    Section "Monitor"
        Identifier "Monitor0"
        VertRefresh 50-100 # make sure this is in line with what your monitor can handle
        HorizSync 30-50 # again, make sure this is the correct range for your monitor
        Option "dpms"
    EndSection "Monitor"
    
    Section "Device"
        Identifier "Device0"
        Driver "vesa"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device "Device0"
        Monitor "Monitor0"
        DefaultDepth 24
        SubSection "Display"
            Depth 24
            Modes "1024x768"
        EndSubSection
    EndSection
    
    # Make sure that your Section "ServerLayout" has the following lines:
    
    Section "ServerLayout"
        ... # the first part we don't care about
        Screen 0 "Screen0"
        ... # the last part we don't care about
    EndSection

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    Hm. When I use
    $EDITOR /etc/X11/xorg.conf
    I get a
    -bash: /etc/X11/xorg.conf Permission Denied
    I am logged on as a root user yet my permission still is denied.

  9. #8
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    do this, then edit the file again:
    Code:
    chmod 644 /etc/X11/xorg.conf

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Location
    Saginaw, Michigan
    Posts
    28
    The chmod goes through but access is still denied. Sooo frustrating...

  11. #10
    Linux Enthusiast
    Join Date
    Dec 2004
    Location
    Rockin' in the USA!!!
    Posts
    603
    tell me what this says:
    Code:
    ls -l /etc/X11/xorg.conf

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •