Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Internet connection problems...


    My computer has a LAN connection and after setting up all parameters - IP, DNS, Gateway, etc.. i'am not able to load Web pages or these pages are loading very slow. I.e Others are loading very quick ( google, I did the same test from Windows XP and Knopix and there are no problems. I'm currently using Mandrake 10.1 . Any suggestion?
    The traceroute shows me that the 4-5 hop didn't answer. I noticed some checksum errors in the sniffer. Is this a known issue....

    P.S. - I'm using a nonroutable IP address mapped one to one ( using NAT ) to a routable address


  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Rockin' in the USA!!!
    Are you using a local DNS server, it sounds like it might be a problem with that... what's the output of:

  3. #3
    The DNS is but I think it just forward the request

    root@gogu root]# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0 eth0
    default         UG    0      0        0 eth0
    [root@gogu root]#

  4. $spacer_open
  5. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Rockin' in the USA!!!
    first, post your /etc/conf.d/net.eth0 file, and try going between dhcp and static configuration, and make sure that portmap is running, just type 'portmap' without quotes in the terminal.

  6. #5
    There is no file you mentioned, but I supposed this is what you want. I changed the METRIC from 10 to 30, BTW I'm posting this messages from my Linux and I have no traceroute to It is so slow.....

    [root@gogu root]# more /etc/sysconfig/network-scripts/ifcfg-eth0
    [root@gogu root]#

  7. #6
    I'd be interested in a solution as well, I've been hunting around for a couple of weeks trying to find a fix to the same issue.

    I've tried pretty much everything that I've found out on the Web and I'm nearly at wits end.

  8. #7
    Have you tried using a DNS that your ISP gave you? or a public DNS server. In my DNS servers, i have my ISP's dns servers, and my connection is working nicely. It could be that your internal DNS server doesn't have that many entries, so if u ask it to translate say to an ip it is taking a long time because it then has to figure it out (if it knows how)
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  9. #8
    I looked into my router's firewall security log and located my ISP's two DNS server addies.
    I then used Mandrake control center to manually build a new lan connection under Network and Internet.
    I plugged in the two DNS server numbers I found as DNS servers one and two. Is there some way to confirm that Mandrake isn't ignoring the new DNS's?
    I seem to be having mixed results, but essentially I established a static IP connection with my router. I'll have to keep plugging away at it.


  10. #9
    u built a new lan connection? So u essentially have eth0 and eth1? If u want to use internal DNS to resolv local computer names, just add the local DNS server to a new line on the end of /etc/resolv.conf after the word name server eg;

    but change to the local DNS server
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  11. #10
    I have only eth0 and no internal DNS. The DNS that ISP has gave me does only caching ( i guess ). The small number of entries doesn't explain why form Knopix and XP works fine..

    finklewicz - did you try another OS on the same connection?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts