Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi i have a problem when i try to shut down my computer. I have Mandrake Linux 10.1 on a dell dimension computer Pentium II. It shuts down everything [ ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7

    Problems turning off the computer


    Hi i have a problem when i try to shut down my computer.
    I have Mandrake Linux 10.1 on a dell dimension computer Pentium II.
    It shuts down everything [ OK ] except the ibod-deamon. But when it says:
    Sending all processes the TERM signal [OK]
    Sending all processes the KILL signal [OK]
    Saving random seed [OK]
    Turning off swap [OK]
    Unmounting file systems [OK]
    Unmounting proc file system [OK]
    Halting system....
    md: stopping all md devices
    md: md0 switched to read-only mode
    Shutdwon hda
    Power down
    something inside the computer switches off but the screen is still on, i can see all the text and the fan is still runnig. To shut it down completely i need to press the reset button and then the power button.

    I'm new to linux, please help me!

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    I have heard stuff like this before, the firewall computer that my brother runs does this aswell, i could be wrong, but i have a feeling it's something to do with the power management. when u boot linux, try adding acpi=off to the kernel parameters and then try a shut down.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    If acpi=off doesn't work, you may have to use acpi=force

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    Thanks for your help!

    But unfortunately i'm totally new to linux so i don't really know where and when to make this change...

  6. #5
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    In Mandrake, you can go into the Mandrake Control Center's Bootloader Configuration module and there are check boxes there for noapic and acpi.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    Oops! I think i did something silly now. I tried to make the changes as Flatline told me. So i checked and unchecked the activate acpi box in MCC but nothing happened. Then i started to check the other checkboxes on that page and now mandrake wont start again!! Where can i change back to the previous settings?

    Thanks a lot!

  8. #7
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    What, exactly, did you change? You can boot from the install CD, hit F1 for other boot options, and select Rescue to get to your files and bootloader.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  9. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    I changed to "don't force apic" and "don't force local apic"

  10. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7
    I chose to start up linux-nonfb now and it seems to stop at "Calibrating delay loop..."

  11. #10
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    If you boot from the install cd in Rescue mode, you'll get a dialog that lets you mount your partitions under /mnt. Do it. Then you can edit your /etc/lilo.conf file (which at that point will actually be /mnt/etc/lilo.conf) and reinstall your bootloader. You will want to look at the lines that say append and remove the noapic stuff. Remember that until you reinstall lilo your changes won't take effect.
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •