Find the answer to your Linux question:
Results 1 to 3 of 3
Hi! I'm having some problem with my ethernet connection eth0, when I start it up it takes like five minutes before it starts, but there's no problem with the internet ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8

    No DHCPOFFERS received??


    Hi!
    I'm having some problem with my ethernet connection eth0, when I start it up it takes like five minutes before it starts, but there's no problem with the internet it's just the time it takes before it starts.
    Anyway, here's my output of dhclient eth0;

    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/eth0/00:60:08:54:9e:64
    Sending on LPF/eth0/00:60:08:54:9e:64
    Sending on Socket/fallback
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
    DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 12
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.

    If yu know how to fix this then please tell me, it's quite annoying.

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    It means there are no DHCP server's on your network.

    This means you should either:
    a) Install a DHCP server on another PC on your network (generally NOT recommended, unless you absolutely KNOW you need to do it!)
    b) (easier), configure your PC to use a static IP address, instructions follow:

    NOTE: If your internet connection is provided by eth0 DONT do any of this!

    1) As root, open /etc/sysconfig/network-scripts/ifcfg-eth0 in a text editor
    2) set these values in the file like so:
    Code:
    DEVICE=eth0
    BOOTPROTO=static
    IPADDR=192.168.1.2
    NETMASK=255.255.255.0
    NETWORK=192.168.1.0
    BROADCAST=192.168.1.255
    ONBOOT=yes
    NOTE: If any of the options are commented out (preceeded by a #) then you need to remove the #.

    3) save the file.

    Of course adjust the settings according to your network setup.

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Thank you very much! It works very well now, actually the only thing I had to do was to copy the things you wrote and then just paste it in that file you redirected me to, without having to edit it .

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •