Find the answer to your Linux question:
Results 1 to 7 of 7
Hello again, I gave up on solving a problem of mine, maybe you can find out how I could restore my system to its right appearance My system fonts have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    209

    HELP ! Editing size of system fonts


    Hello again,

    I gave up on solving a problem of mine, maybe you can find out how I could restore my system to its right appearance

    My system fonts have become one or two sizes too small, or maybe did they change from a font to another, I'm not sure.

    I have a Mandrake 10.1 discovery, and the reason of the bug is probably an RPM installation, I installed plenty so as to have development toos, graphic libs to install picture software, graphic things like xorg to update later on my nvidia.
    One note : my system is in french, but I installed support for English too, so if that helps you, and if you can tell me how to switch (^.^) i'll switch my system to english so that your indications are easier to follow.

    I can update the KDE font and size of fonts, but that does not affect the size of the system fonts, i.e. the fonts used in Konqueror or the fonts used in the Mandrake Control Center.

    If I leave KDE to IceWM, for instance, the system fonts (mandrake control center...) keep exactly the same size and appearance, so it seems the problem is not related to KDE but to the core of the system.



    Here are a few screenshots, the results were the same in root and in single user mode.

    Two screenshots of the problem,
    -
    The Mandrake Control Center, you see the letters are damn small :

    -
    In Konqueror, you can see the contrast between the oversized KDE fonts (I tried setting all of them very very large), and the "system" fonts that are desperately small.

    -


    Two screenshots of my two attempts to solve the problem, in vain of course. Once again, you'll see that I tried to set the fonts to a very big size, so as to be certain that the system fonts were unaffected by those settings :
    -
    The KDE Control Center, from KDE menu

    -
    Konqueror configuration menu. There's a setting "minimal font size", I have set 10 for that value, but alas it didn't improve the system fonts' size. I also tried even size 15 for all settings (not in the screenshots), but the system fonts remained unaffected :

    -


    So, well, please help me if you know what I need to change so that things work for me ^_^

  2. #2
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    209
    bump :-/
    I'm sure there's a way to tweak this setting, sigh :-/

  3. #3
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    209
    Last bump before I give up.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    HELP ! Editing size of system fonts

    sabin,

    I have a problem similar to yours (inconsistent font sizes) and everytime I fix them, "they" revert back to their old ways.

    The thing is, the font changes happen randomly and are out of my control. Every once in awhile after a system reboot, the font sizes change. Either to the same size or not, depending on "who knows what?".

    I'm searching for a solution and if I find it I will post here.
    Mike

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Re: HELP ! Editing size of system fonts

    Quote Originally Posted by mzulkoski

    I'm searching for a solution and if I find it I will post here.
    Mike
    Try this thread at Madriva Club:

    http://forum.mandrivaclub.com/viewto...ighlight=fonts

    I followed the suggestions and it worked . . . at least for now. If the problem isn't fixed, a day or week or month from now my fonts will change again depending (apparently) the whims of Gnome.

    I use KDE on Mandrake 10.1 Official.

    Mike

  7. #6
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    209
    As for me, I'm still, as a newbie, testing the Linux distros, and the Mandrake that had that bug has long since been formatted (currently, i'm bloody searching how to disable some options I hate in Suse, like that single click considered as a double click, or the central click in firefox considered as a request to re-download a file >___<), but yet I remember something :

    In Mandrake, two weeks after I had that bug that I couldn't solve, I updated the system with the kernel, kde, security updates and bugfixes, and in the end, the bug with the fonts had disappeared.
    So all in all, in my case, that might have been due to a misprogramming of a Mandrake updated element...

  8. #7
    Linux Newbie sabin's Avatar
    Join Date
    Apr 2005
    Posts
    209

    Hmm

    Weird enough, the problem happened again on my fresh install of a Mandrake Discovery 10.1, precisely after I installed gtk and g++ and libjpeg and libpng and ghostscript (I installed them all so as to be able to compile GQview from source).

    I EDIT MY ORIGINAL POST :
    At first I said that :
    I read the Mandrake Club thread, but the process described to change the DPIs is far beyond my range, alas.
    Finally, I read the thread at mandrakeclub twice and found that was not impossible all in all.
    Moreover, I found that just doing the first step was quite enough, who'd have believed that ! Editing /etc/X11/Xresources was enough !
    Great, isn't it ? ^_^

    NEW EDIT :
    Finally, things turned even more interesting.
    Just in case, I followed all the steps listed on that mdk club thread, and not the very first one. And though I cannot tell what has changed, I can clearly say that I see, after a system reboot (sorry, don't ask me to exit X and manually restart it - not yet ^^), that fonts are more beautiful now.

    Thanks for tipping us to that thread :o)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •