Find the answer to your Linux question:
Results 1 to 7 of 7
I installed my nvidia driver but I can´t get my GLX direct rendering enabled. Can someone please help me out?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    GLX direct rendering?!


    I installed my nvidia driver but I can´t get my GLX direct rendering enabled. Can someone please help me out?

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    Is the driver being fully used? I know there is an issue where if it isn't listed in /etc/modules.preload it won't be seen. I was working happily using my nVidia driver but never appended that entry - consequently I did not see full rendering , and a lot of XScreensavers wouldn't work.

    Just throw in the value nvidia and see how you get on. Run the glxgears command to see if it works.

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    10

    see this howto


  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    It says the new kernels have the file ¨modprobe.preload¨ so I just added a line ¨nvidia¨ to that file. I will see if it works and let you know.

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    I edited my file, and still I have no direct GLX rendering?! My nvidia driver loads, it is just the GLX direct rendering.

  6. #6
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    So the driver shows up when you run lsmod and you still have no glx? Did you edit the "Device" section of your /etc/X11/xorg.conf file so that the driver listed is nvidia and not nv?
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32
    Yes I did that. I don´t know if it has something to do with the updates I downloaded because now I can´t install the new nvidia drivers. Everything with the installation goes fine until the ¨build kernel module¨ is almost complete then it throws the following error: ¨Unable to load the kernel module ´nvidia.ko´. This is most likely because the kernel module was built using the wrong kernel source files. Please make sure you have installed the kernel source files for your kernel . . . . If you know the correct kernel source files are installed, you may specify the kernel source path with the ´--kernel-source-path´ commandline option.

    I checked and I have the kernel source code installed. In point2play of cedega when I run the system test is says ¨Open GL Direct Rendering - Not available¨. Also in my nvidia settings utility it says ¨Direct rendering - no¨.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •