Find the answer to your Linux question:
Results 1 to 9 of 9
Has anybody managed to get an SB Audigy 2 value sound card to work?? I've got Mandrake 10.1 on my system and have had no luck to date. Upon boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    41

    Sound card issues


    Has anybody managed to get an SB Audigy 2 value sound card to work??

    I've got Mandrake 10.1 on my system and have had no luck to date.

    Upon boot I see in the services that neither the alsa or sound is running (had some issues during setup and was advised to do a chkconfig --level 2345 alsa off and chkconfig -- 345 sound off.)

    Attempting to launch the sound service only gives me the following msg:

    loading sound module [snd-emul10k1] ok
    alsactl: save_state:1066 no soundcard found
    cant open /root/tmp/asound.state_tmp no such file of directory
    setting mixersetting alsactl:load state 1139: no soundcard found [failed]

    Obviously no sound at this point.

    Then rebooted and in the service launched the alsa service. Got the following msg:
    alsa driver isnt running
    starting alsa version 1.0.6 emu10kr1 [ok]
    doing alsactl to restore mixer setting [ok]

    However no sound is provided (trying to play from a CD)

    Can anybody provide any pointers on where to go from here please?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Try opening a console and typing alsamixer. This will bring up an ncurses mixer for ALSA. Use the arrow keys to navigate left and right: you'll have a lot of channels. Use the up arrows to max out most of your channels. Bear in mind that turning some of them up too far could lead to feedback ... It's not a science, just try to find the right balance.

    Also look at kmixer and be aware of channels/volume settings in there. It's easier to use and more convenient.

    Type man amixer and learn a bit more about that. Just typing amixer in a terminal will bring up a list of muted/unmuted channels.

    Hope this helps.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    looks like you have the wrong driver installed for your soundcard.

    type lspci | grep audio ......to find out your soundcard and chip manufacturer.

    then you can look for your card here and download the source for the driver and install: http://alsa-project.org/alsa-doc/

    this probably is not the easiest fix to your problem. I have not used mandrake so I'm unfamiliar with the built in gui install and package management system with that distro. It might be as easy and checking in the menu somewhere under sound and looking for you card manually in a list and selecting it. The problem seems to be that your card is not auto detected. Therefore you may already have the driver with your distro it is just not selected. Hope this helps more than confuses.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    41
    My mixer levels are all maxed - still no sound.

    I ran the lspci | grep Audio and this confirmed that I have a SB Audigy 2.

    I then looked on the URl and got very confused on which driver to download -there appeared to be loads so I go lost here

    I also assume that as my card was proved by ell it the pci oem (dell version that I want)?

  6. #5
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I did some research and found that your card is not very well supported but there is this thread which suggests some possible solutions. But since, as this thread states, the card is only about thirty bucks I suggest getting a new card and don't deal with the trouble but if it is worth it check this thread out and I'll see if I can find anything else and I post it.

    http://ubuntuforums.org/showthread.php?t=13366
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  7. #6
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Also - and I'm not wanting to insult your intelligence - is your CD/DVD hooked up to your card with a cable? I still like to do that

    Maybe, as the other guy suggests, it's a driver problem, in which case it might be a case of trying different ones.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    41
    Hi guys,

    Appreciate your responses on this. I shall have to think about getting a new card... need to see what impact this will have on my pc warrenty.

    I shall also try to play an mp3 track later - just in case there is an issue with sound directly from CD

  9. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    1
    I have an Audigy 2 as well and i think i had the same issue when i installed Mandriva. It turned out that the default setting is digital instead of analog. All i needed to too was change that setting in kmix, where its listed under the switches tab.

  10. #9
    Just Joined!
    Join Date
    May 2005
    Location
    Figueira da Foz, Portugal
    Posts
    12
    I also have a audigy 2 i have sound and i can play cd's the only thing I did was to set up every thing with alsamixer, for inputs press "F4" i think. Remenber our sound card is on digital exit by default so you have to change it. But i think you have some kind of driver error.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •