I need to apply the BadMem patch to Linux for my laptop with integrated memory. Problem is that the 10.1 Official Mandrake uses kernel 2.6.8.1 and the newest BadMem patch is 2.6.4. Is there a chance that this will work? It seems like I'll just have to use an older distro, but I don't understand the kernel or patch numbering system.