Greetings,

I have read and read and tried a number of things, but am stuck.
My motherboard crapped out on my, and so like any typical guy I lifted myself out of depression with a nice new Gigabyte K8NSC and AMD +3000.
I have a split hard drive running mandrake and windows, and everything was fine before mobo failure.
I reloaded Mandrake (and windows) and everything works fine except network(and internet).
Connection works fine in Windows, hence hardware is good.
There is linux driver software on the mobo cdrom, but i don't know how to make it work
My eth0 fails to load at startup(obviously) and I have run through the MCC connection wizard several times
It seems to recognize my onboard Lan, as the driver is the marvell8001.
but initialization fails everytime.
How do I load the drivers from the cdrom? And where do the drivers go?
On the cdrom are four files: install.sh, readme, sk98lin.4 and sk98lin.tar.bz2

when i run lsmod in root, it shows sk98lin in the list

when i run ifconfig it shows proper eth0 info, i.e. IP addy, Bcast, Mask
and also has
lo link encap : local loopback
inet addr: xxx.0.0.x Mask xxx.x.x.x
............... and on and on

HOW do i proceed?
I cannot get email or network or internet.
Any help for this newbie is appreciated.