Find the answer to your Linux question:
Results 1 to 5 of 5
OK, Mandrake installed, runs perfect on the 2nd drive as "slave", on /dev/hda "Master" I have Xandros installed. But after restart Mandrake boots up. In Configure Your Computer the boot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28

    start /dev/hda


    OK, Mandrake installed, runs perfect on the 2nd drive as "slave", on /dev/hda "Master" I have Xandros installed. But after restart Mandrake boots up. In Configure Your Computer the boot licon lists /dev/hda first. On the Mandrake Desktop I clicked the New Device to Hard Disk, typed info, when clicked I get:
    "can't find /dev/hda in /etc/ftstab or /etc/mtab.
    Thanks,

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Okay - just a quick reply I'm afraid. Go into your BIOS at boot time and change the boot order. I suspect that your slave drive is set as the primary boot device.

    You will have to edit fstab to add the drive you are having trouble accessing. For this, you need to be root. Open a console... type man mount Read the wisdom that lies within :o

    su
    your password
    vim /etc/fstab ---- maybe you could try
    kate /etc/fstab
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    28

    drives

    Bios lists drives in correct order
    Typed in your code as root into terminal:
    No such Device
    I pasted into terminal from the window:
    /dev/hda /etc/ftstab
    Permission Denied...
    Typed in diferent combos: Permission Denied

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Obvious question: did you auth as root?
    Mehz

  6. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hmm ... I have no idea why your machine reboots into your slave drive. It may be something to do with your lilo settings... I rarely touch that myself.

    Like I said, if you want to mount and read your drive you need to add it to the fstab file otherwise your system won't know it's there.

    /dev/hda /mnt/mydrivea ext3 defaults 0 0

    The above line assumes the following: you are using the ext3 file system and you have a directory in /mnt called 'mydrivea' It doesn't matter what you call that directory by the way...

    This might help you a bit.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •