Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I have a dual boot linux/win98 and linux is a headache at times. When I browse the mnt/ directory, it shows my FAT partitions as empty or identified wrong!!?? I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146

    mnt list doesnt' show partitions content


    I have a dual boot linux/win98 and linux is a headache at times. When I browse the mnt/ directory, it shows my FAT partitions as empty or identified wrong!!?? I have two HDs which /mnt shows as hd and hd2 and win_c and win_c2. Clicking hd shows the content of win_c2 and hd2 is shown empty. What's worse when I click on win_c2, that shows as empty??!! and win_c shows gibberish directories that don't exist along with the regular content

    How do I configure /mnt to show only win_c and win_c2 and my linux partitions (hd5 and hd7 home)???

    On a similar subject:when I insert a cd in my CD2 (cdrw drive), KDE3.2 pops a cd icon on my screen instead of transparently detecting the inserted cd in the browser only. Any ideas to fix that...

    any help would be appreciated.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Did you try mounting the hard drives before clicking on it?

    Whats your /etc/fstab file with regards to the two hard drives:
    it should be somthing like:
    /dev/hda1 /mnt/windows vfat umask=0,iocharset=iso8859-1,nls=iso8859-1,codepage=850,rw 0 0

    about your cd drive, again post the fstab line for the drive. It will only add to browser if you have set the fstab file to supermount cdroms. In all other cases, you should type mount /mnt/cdrom into a terminal in order to see it.

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    Here is my fstab file: I would like to edit it with vim such that my partitions are named properly in a logical way that is easy to work with. ie.
    win_c would be my hda1 fat32 partition
    win_c2 would the second HD fat32
    my linux partitions could be hd5 and hd7
    then cdrom and cdrom2 for my cdrom and cdrw drives
    floppy reamain as is

    Code:
    /dev/hda5 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    /dev/hda7 /home ext3 defaults 1 2
    /dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
    /dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
    none /mnt/hd supermount dev=/dev/hdb1,fs=vfat,--,umask=0,iocharset=iso8859-1,codepage=850,kudzu 0 0
    /dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,codepage=850 0 0
    none /proc proc defaults 0 0
    /dev/hda6 swap swap defaults 0 0
    none /mnt/hd2 supermount dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Ok, the problem is that you have too many fstab entries, change your fstab to look something like this:
    Code:
    /dev/hda5 / ext3 defaults 1 1
    /dev/hda7 /home ext3 defaults 1 2
    /dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec,users 0 0
    /dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,rw,exec,users 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
    /dev/hda1 /mnt/win_c vfat umask=0,iocharset=iso8859-1,nls=iso8859-1,codepage=850,rw 0 0
    /dev/hdb1 /mnt/win_c2 vfat umask=0,iocharset=iso8859-1,nls=iso8859-1,codepage=850,rw 0 0
    none /proc proc defaults 0 0
    /dev/hda6 swap swap defaults 0 0
    Now to use these directories, you must as root, create directories /mnt/win_c and /mnt/win_c2. Now whenever you want to see those directories, as a normal user you can type into a terminal
    Code:
    mount /mnt/win_c
    to see the c: drive. Similarly, type mount /mnt/win_c2 to see your d(?) drive.

    Supermount is problematic to say the least, it is mainly used to automatically mount/unmount ermoveable devices such as floppy drives.

    Also, i assume that your /mnt/cdrom2 is your cd-rw, and that is why it has an rw for its mount parameter in the fstab file. Note, when you try to mount non-writeable cd's, an error will pop up and let you know that the cd can't be written to. Just ignore this and you can still see the stuff on the cd.

  6. #5
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    Thanks for the answer. I will update the fstab.
    But one thing I'm wondering about: Why can't the mounting of the volumes or partitions be done automaticaaly and/transparently such as at start-up or when win_c or win_c2 is accessed from a browser?

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Try this, going over your original fstab file, you had too many mount points for the 2nd hard drive. I think it may work, but im not sure as i try to limit my dependancy on windows.

    Code:
    none /mnt/win_c supermount dev=/dev/hda1,fs=vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0

  8. #7
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    I edited my fstab as discussed. But now I get a 'too many partitiions mounted error' at start-up and the following line is appended to my fstab file :
    Code:
    dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
    Also since editing it, my shell wont start-up from KDE. even rxvterminal!!!I had to hit ctl-alt backspace to get to the command line to edit the fstab from root. When I commented out the line above, it showed up appended again to the fstab file after a reboot. And the partitions still show up empty adn/or unmounted. what gives???

    fstab file is supposed to be straight forward -tying volume labels to hardware mount points. My file systems are regular ext2 and vfat. Is there another variable at startup that might be overiding fstab? any help would be appreciated.

  9. #8
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Does this happen when you try to supermount the drive? if so, reset it back to the fstab file in my first post.

    By the way, you can use any editor to edit the fstab file, no need to goto command line to edit it. Simply do a chmod 606 as root to the /etc/fstab file and use any editor like Kwrite or Xemacs to edit it. Once you are done, simply chmod 600 the file.

    the only time that the fstab file will be amended during startup is that if a new device/partition has been detected. Also I don't think it is possible to comment a fstab file, just delete the offending entry.

  10. #9
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    146
    Does this happen when you try to supermount the drive? if so, reset it back to the fstab file in my first post.
    I edited the entire fstab to the posted one. But, like I said, after rebboting, it appends the following in the last line.

    Code:
    dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0
    I didn't supermount any drives.

    ???

  11. #10
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    While I'm not sure what the problem is here, is kudzu strictly necessary? I just noticed that it's mentioned in your auto-generated fstab line. If not (I believe it checks for new hardware) maybe you could ditch it.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •