Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Ok, I downloaded jre-1_5_0_02-linux-i586-rpm.bin and did get that installed, so now the installed file is under: /home/me/jre-1_5_0_02-linux-i586.rpm I was told I need to link to that file, so I changed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8

    Can't get JRE to work in Firefox on Mandriva LE 2005


    Ok, I downloaded jre-1_5_0_02-linux-i586-rpm.bin and did get that installed, so now the installed file is under:

    /home/me/jre-1_5_0_02-linux-i586.rpm


    I was told I need to link to that file, so I changed the dir to the mozilla plugins dir, which is:

    /usr/lib/mozilla/plugins

    And then, I did the whole installation thing according to Sun's site:

    ln -s /home/me/plugin/i386/ns7/libjavaplugin_oji.so


    Then, I was told to go to Edit / Preferences / Advanced to enable Java, but there is no option for that in Advanced.

    While I was putting the link for JRE into the plugin dir, I removed the older version of JRE. The old version of java under Konsole was blue, but what I just installed is flashing red. Now, I have no Java and I have no idea how to configure the newer version on my comp. I am stumped! BTW, my Firefox version is 1.0.2. Any help would be appreciated!

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Posts
    13
    Enable java is under Web Features in Preferences, not Advanced.

    If you get Java working in Firefox, let me know, cuz I installed it according to the instructions, made all the appropriate links and still no go.

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Alright, I found that Java was enabled under Firefox. But, it's still not working. When I go to the "Test JVM" page, I still have no Java.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    I believe (if I remember right) you'll need to find the Firefox plugins directory and do the link there. From your posts, you're linking to the Mozilla browser not the Firefox broswer. Hopefully I got it right and that this helps you out.

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Well, I found the Firefox plugin directory:

    /usr/lib/mozilla-firefox-1.0.2/plugins

    and did the link, but still no Java. Am I linking to the file correctly? Should it actually be:

    ln -s /home/me/plugin/i386/ns7/libjavaplugin_oji.so

    or should it be:

    ln -s /home/me/jre-1_5_0_02-linux-i586.rpm/plugin/i386/ns7/libjavaplugin_oji.so

    or something similar to that instead? Did a JVM test, and nothing happened. Once I get this working, and then hopefully Azureus, I can finally pull away from windows. But until then, I have to keep going back to XP to get torrents.

  7. #6
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    Since you're in the Firefox plugin directory, you can just type in:

    Code:
    ln -s /usr/java/jre-VERSION/plugin/i386/ns7/libjavaplugin_oji.so
    Just replace VERSION with the Java version in the /usr/java directory (this is assuming you made a java directory under /usr). Give it a shot and let me know how it goes.

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Man! Ok, I did that and I was certain Java was going to work. When I went back to the "Test JVM" page:

    http://www.java.com/en/download/help/testvm.xml

    The following message was displayed:

    Congratulations. The latest version is installed on your system.
    Your java configuration is:
    Vendor: Sun Microsystems Inc.
    Version: 1.5.0_02
    OS: Linux
    OS version: 2.6.11-6mdk

    BUT, no Java animation that I saw under my older version of Java. Firefox is not prompting to install a plugin, so it must be working, just somehow not configured right. And it says "Applet testvm started" in the lower left corner of the browser window. Also, the page is taking longer to load than usual, and has crashed a couple of times already. And I have reloaded it/cleared my cache. Maybe I should just reinstall it?

  9. #8
    Linux User
    Join Date
    Mar 2005
    Location
    CA
    Posts
    352
    I would suggest reinstalling it, but I'm not too sure how to uninstall it though. I'm new to linux myself, so I'm still in the learning process.

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    8
    Well, I uninstalled it, meaning I removed the previous files/links that I installed, and reinstalled it again and the same thing is going on, Javas test page says my browser is ok, but there is no animation. I've been to other test pages not associated with Sun that say the same thing. But the thing is, even though animation doesn't work, there were Java applet games that I could play, such as connect 4, scrabble, etc. My browser can handle that. I don't know what to do. Maybe I should just reinstall Mandriva? It's not like I have anything of value on here yet. I deleted the older Java version to get the new version on here, maybe I deleted something crucial. But since I only made sure to delete the older Java version, this should be working! I'm out of ideas!

  11. #10
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    fire-fox and mandiva le2005

    Try ,

    ln -s /usr/java/JRE/jre/plugin/i386/ns7/libjavaplugin_oji.so

    where /usr/.........................

    is the path to the libjavaplugin

    then

    copy the link created into the fire-fox/plugin folder.

    I am new to linux however got luck with this. I am sure someone will so refine this roughy.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •